Améliorer et dépanner EIGRP pour IPv4/IPv6

Réglages fin de EIGRP pour IPv4/IPv6

Aujourd’hui, nous passons en revue les commandes de raffinement et de dépannage d’une implémentation EIGRP. Nous envisageons l’utilisation d’un résumé automatique (automatic summarization), la modification du coût, la propagation d’une route par défaut, et la modification des timers (timers). Nous terminons vet article par des commandes et une méthodologie de dépannage EIGRP.

Modification de EIGRP pour la configuration IPv4

Comme pour l’OSPF, la configuration EIGRP peut être modifiée de plusieurs façons, notamment en activant le résumé automatique (automatic summarization), en propageant une route par défaut, en modifiant la valeur de la bande passante et en ajustant les temporisateurs avec précision.

Résumé automatique (automatic summarization)

Par défaut, le résumé automatique des routes EIGRP est désactivé. Le résumé de routes permet à un routeur de regrouper les réseaux et de les annoncer comme un grand groupe en utilisant une seule route résumée. La figure A montre un exemple du fonctionnement du résumé automatique.

Figure A - Récapitulation automatique dans EIGRP
Figure A – Récapitulation automatique dans EIGRP

R1 et R2 sont tous deux configurés à l’aide de EIGRP pour IPv4, avec résumé automatique activé. R1 a trois sous-réseaux dans sa table de routage : 172.16.1.0/24, 172.16.2.0/24 et 172.16.3.0/24.

Dans l’architecture d’adressage réseau classful, ces sous-réseaux sont tous considérés comme faisant partie d’un réseau de classe B plus large, 172.16.0.0/16. Comme EIGRP sur R1 est configuré pour le résumé automatique, lorsqu’il envoie sa mise à jour de routage à R2, il résume les trois sous-réseaux /24 comme un réseau unique de 172.16.0.0.0/16.

Ceci réduit le nombre de mises à jour de routage envoyées et le nombre d’entrées dans la table de routage IPv4 de R2.

Pour activer la compression automatique, saisissez la commande auto-summary en mode de configuration du routeur, comme dans l’exemple A.

Exemple A – Activation de la récapitulation automatique

R1(config)# router eigrp 1
R1(config-router)# auto-summary

R2(config)# router eigrp 1
R2(config-router)# auto-summary

R3(config)# router eigrp 1
R3(config-router)# auto-summary

 

REMARQUE : Il est probablement préférable de laisser la compression automatique désactivée parce que cela garantit que, même lorsque des sous-réseaux sont attribués de manière discontiguë, les informations de routage se propagent toujours dans l’ensemble du domaine de routage EIGRP.

Topologie EIGRP pour IPv4

Notre examen de la mise au point de l’EIGRP pour IPv4 utilise la topologie de la Figure B.

Figure B - Topologie EIGRP pour IPv4
Figure B – Topologie EIGRP pour IPv4

Propagation de route par défaut IPv4

La route statique par défaut quadruple zéro peut être utilisée avec tous les protocoles de routage actuellement pris en charge. Dans cet exemple, nous configurons la route statique par défaut sur R2 car elle est connectée à Internet. L’exemple B montre la configuration de la route statique par défaut sur R2.

Exemple B – Configuration et redistribution de route par défaut dans EIGRP

R2(config)# ip route 0.0.0.0 0.0.0.0 Serial0/1/0
R2(config)# router eigrp 1
R2(config-router)# redistribute static

 

La commande redistribute static indique à EIGRP d’inclure cette route statique dans ses mises à jour EIGRP vers d’autres routeurs. L’exemple C montre la table de routage de R1, avec la route par défaut surlignée.

Exemple C – Table de routage de R1 avec la route par défaut installée

R1# show ip route eigrp
  172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
D 		172.16.2.0/24 [90/3524096] via 192.168.10.6, 00:06:27, Serial0/0/1
D 	192.168.0.0/22 [90/2170112] via 192.168.10.6, 00:06:28, Serial0/0/1
  192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D 		192.168.10.8/30 [90/3523840] via 192.168.10.6, 00:06:28, Serial0/0/1
D*EX 	0.0.0.0/0 [170/8643840] via 192.168.10.6, 00:00:14, Serial0/0/1
R1#

 

Le code D*EX est interprété comme suit :

  • D : Cette route a été apprise via EIGRP.
  • * : Cette route est actuellement la route par défaut candidate.
  • EX : Cette route est une route externe. Notez la distance administrative de 170.

Modifier la métrique EIGRP

Comme la largeur de bande passant peut prendre par défaut une valeur qui ne reflète pas la valeur réelle, vous pouvez utiliser la commande d’interface bandwidth pour modifier la mesure de la largeur de la bande passante de l’interface :

Router(config-if)# bandwidth kilobits

Dans la topologie de la figure A, notez que la liaison entre R1 et R2 a une bande passante de 64 kbps, et la liaison entre R2 et R3 a une bande passante de 1024 kbps.

L’exemple D montre les configurations utilisées sur les trois routeurs pour modifier la largeur de bande passante.

Exemple D – Modification de la bande passante

R1(config)# interface serial 0/0/0
R1(config-if)# bandwidth 64
R2(config)# interface serial 0/0/0
R2(config-if)# bandwidth 64
R2(config-if)# interface serial 0/0/1
R2(config-if)# bandwidth 1024

R3(config)# interface serial 0/0/1
R3(config-if)# bandwidth 1024

REMARQUE: Le processus de modification de la bande passante est le même que l’interface soit configurée avec un adressage IPv4 ou IPv6.

Modification des intervalles Hello et Hold

Les intervalles Hello et les temps d’attente sont configurables par interface et n’ont pas besoin de correspondre avec d’autres routeurs EIGRP pour établir des adjacences. La syntaxe de la commande de modification de l’intervalle Hello est la suivante :

Router(config-if)# ip hello-interval eigrp as-number seconds

Si vous modifiez l’intervalle Hello, assurez-vous que vous modifiez également le temps de maintien (hold time) à une valeur égale ou supérieure à l’intervalle Hello.

Sinon, l’adjacence des voisins tombera en panne après l’expiration du temps de maintien et avant l’intervalle Hello suivant. La commande de configuration d’une durée de maintien différente est la suivante :

Router(config-if)# ip hold-time eigrp as-number seconds

La valeur en secondes pour les intervalles Hello et Holdtime peut varier de 1 à 65,535. Dans l’exemple E, R1 et R2 sont configurés pour utiliser un intervalle Hello de 60 secondes et un temps de maintien de 180 secondes.

Exemple E – Modification des intervalles Hello et Hold

R1(config)# interface s0/0/0
R1(config-if)# ip hello-interval eigrp 1 60
R1(config-if)# ip hold-time eigrp 1 180

R2(config)# interface s0/0/0
R2(config-if)# ip hello-interval eigrp 1 60
R2(config-if)# ip hold-time eigrp 1 180

 

Modifier EIGRP pour IPv6

La modification de EIGRP pour l’implémentation d’IPv6 comprend la propagation d’une route par défaut, la modification de la valeur de la bande passante et le réglage fin des timers.

Topologie EIGRP pour IPv6

Nous utilisons la topologie de la Figure C dans notre étude de EIGRP pour la modification IPv6.

Figure C - Topologie EIGRP pour IPv6
Figure C – Topologie EIGRP pour IPv6

Propagation de route par défaut IPv6

La propagation d’une route par défaut dans EIGRP pour IPv6 est exactement la même que dans EIGRP pour IPv4. Configurez la route statique par défaut et entrez la commande redistribute static en mode configuration du routeur, comme dans l’exemple F.

Exemple F – Propagation de route par défaut dans EIGRP pour IPv6

R2(config)# ipv6 route ::/0 serial 0/1/0
R2(config)# ipv6 router eigrp 100
R2(config-rtr)# redistribute static
R2(config-rtr)# end
R2#

 

R1 et R3 ont maintenant une route par défaut, comme vérifié avec la commande show ipv6 route dans l’exemple G.

Exemple G – Routes par défaut dans les tables de routage de R1 et R3

R1# show ipv6 route
<texte omis>
EX 	::/0 [170/7289856]
    via FE80::2, Serial0/0/0, receive
R1#

R3# show ipv6 route
<texte omis>
EX 	::/0 [170/7289856]
    via FE80::2, Serial0/0/1, receive
R3#

 

Modification de l’utilisation de la bande passante

Par défaut, EIGRP n’utilise que jusqu’à 50 % de la bande passante d’une interface pour les informations EIGRP. Cela empêche le processus EIGRP de sur-utiliser une liaison et de ne pas laisser suffisamment de bande passante pour l’acheminement du trafic normal.

Utilisez la commande ip bandwidth-percent eigrp pour modifier le pourcentage de bande passante que EIGRP peut utiliser sur une interface :

Router(config-if)# ipv6 bandwidth-percent eigrp as-number percent

Par exemple, supposons que R1 et R2 partagent une liaison très lente de 64 kbps. L’exemple H montre comment configurer EIGRP pour réduire l’utilisation par défaut à 40 %.

Exemple H – Modification de l’utilisation de la bande passante

R1(config)# interface serial 0/0/0
R1(config-if)# ipv6 bandwidth-percent eigrp 100 40

R2(config)# interface serial 0/0/0
R2(config-if)# ipv6 bandwidth-percent eigrp 100 40

 

NOTE: Le processus pour modifier l’utilisation de la bande passante est le même que pour IPv4, sauf que la commande utilise ipv6 au lieu de ip.

Modification des intervalles Hello et Hold

EIGRP pour IPv6 utilise le même intervalle Hello et les mêmes temps de maintien que EIGRP pour IPv4. Les commandes du mode de configuration de l’interface sont similaires à celles d’IPv4 :

Router(config-if)# ipv6 hello-interval eigrp as-number seconds
Router(config-if)# ipv6 hold-time eigrp as-number seconds

L’exemple I montre les configurations de l’intervalle Hello et du temps de maintien pour R1 et R2 avec EIGRP pour IPv6.

Exemple I – Configuration des intervalles Hold et Hello d’EIGRP pour IPv6

R1(config)# interface serial 0/0/0
R1(config-if)# ipv6 hello-interval eigrp 100 50
R1(config-if)# ipv6 hold-time eigrp 100 50

R2(config)# interface serial 0/0/0
R2(config-if)# ipv6 hello-interval eigrp 100 50
R2(config-if)# ipv6 hold-time eigrp 100 50

Commandes de dépannage EIGRP

Plusieurs commandes sont utiles pour dépanner un réseau EIGRP :

show ip eigrp interface : Vérifie quelles interfaces sont activées pour EIGRP, le nombre de pairs et les files d’attente de transmission.

show ip protocols : Vérifie les valeurs EIGRP actuellement configurées pour diverses propriétés de tous les protocoles de routage activés.

show ip eigrp neighbors : Vérifie que le routeur reconnaît ses voisins

show ip route eigrp : Vérifie que le routeur a appris la route vers un réseau distant via EIGRP.

La figure D illustre une méthode d’utilisation systématique de ces commandes.

Figure D - Méthode systématique de dépannage d'EIGRP pour IPv4
Figure D – Méthode systématique de dépannage d’EIGRP pour IPv4

Comme pour le protocole Open Shortest Path First (OSPF), les adjacences de voisinage sont une condition préalable à la convergence EIGRP et nécessitent une connectivité de couche 3.

En examinant la sortie de la commande show ip interface brief, vous pouvez vérifier que l’état et le protocole des interfaces de connexion sont activés. Utilisez les protocoles show ip protocols (ou une autre commande liée à EIGRP) pour vérifier que tous les routeurs sont configurés avec le même numéro de système autonome.

Utilisez la commande show ip eigrp interfaces pour vérifier que toutes les interfaces nécessaires participent à EIGRP.

Vous pouvez utiliser le même processus pour dépanner EIGRP pour les implémentations IPv6. Remplacez simplement l’ip par ipv6 dans la liste des commandes show spécifiques à EIGRP :

  • show ipv6 eigrp neighbors
  • show ipv6 route eigrp
  • show ipv6 protocols
  • show ipv6 eigrp interface

Réseaux discontigus

EIGRP a un problème unique parce que vous pouvez configurer EIGRP pour qu’il résume automatiquement à la limite de classe IP. La compression automatique ne pose aucun problème, tant que le réseau comprimé est contigu au lieu d’être discontigu.

Si la compression automatique est activée dans un réseau discontigieux, vous aurez une situation de convergence moins que complète.

Même une conception de réseau contigu peut devenir discontigue si une ou plusieurs défaillances de liaison divisent un réseau classique en deux ou plusieurs parties. La figure E montre un réseau Internet avec deux réseaux de classes contiguës : 10.0.0.0 et 172.16.0.0.

Figure E - Topologie d'un réseau contigu
Figure E – Topologie d’un réseau contigu

Dans cette figure, avec tous les liens étant activs et les résumés automatiques en vigueur, tous les hôtes peuvent pinguer tous les autres hôtes. Dans cette conception, les paquets pour le réseau 172.16.0.0 circulent sur la route haute et les paquets pour le réseau 10.0.0.0 sur la route basse.

Si un lien entre les routeurs tombe en panne, cependant, l’un des deux réseaux classful devient discontigu. Par exemple, si la liaison entre R3 et R4 échoue, la route de R1 à R4 passe par des sous-réseaux du réseau 172.16.0.0, donc le réseau 10.0.0.0 est discontigu.

La solution consiste soit à concevoir le réseau de manière à éviter la possibilité de sous-réseaux discontigus, soit à désactiver la résumation automatique et à configurer manuellement les routes sommaires.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image