Améliorer et dépanner OSPF v2 et OSPF v3

Améliorer et dépanner OSPF v2 et OSPF v3

L’article d’aujourd’hui se concentre sur l’amélioration et le dépannage des protocoles OSPFv2 et OSPFv3. Le réglage fin de OSPF implique la modification des timers, la conduite d’élections DR/BDR et la propagation d’une route par défaut. Nous nous concentrons également sur le dépannage de processus OSPF.

Exemple de configuration OSPFv2

Pour affiner OSPFv2, nous utilisons la topologie de la Figure A et le schéma d’adressage du Tableau A.

Figure A - Topologie de configuration OSPFv2
Figure A – Topologie de configuration OSPFv2

 

Tableau A – Schéma d’adressage pour OSPFv2

Appareil
Interface
Adresse IP
Masque de sous-réseau
R1G0/0172.16.1.1255.255.255.0
S0/0/0172.16.3.1255.255.255.252
S0/0/1192.168.10.5255.255.255.252
S0/1/0209.165.200.226255.255.255.224
R2G0/0172.16.2.1255.255.255.0
S0/0/0172.16.3.2255.255.255.252
S0/0/1192.168.10.9255.255.255.252
R3G0/0192.168.1.1255.255.255.0
S0/0/0192.168.10.6255.255.255.252
S0/0/1192.168.10.10255.255.255.252

L’exemple A montre les commandes network pour les trois routeurs, activant OSPFv2 sur toutes les interfaces.

Exemple A – Configuration des réseaux OSPF

R1(config)# router ospf 10
R1(config-router)# router-id 1.1.1.1
R1(config-router)# network 172.16.1.0 0.0.0.255 area 0
R1(config-router)# network 172.16.3.0 0.0.0.3 area 0
R1(config-router)# network 192.168.10.4 0.0.0.3 area 0
R1(config-router)# passive-interface g0/0
R1(config-router)# auto-cost reference-bandwidth 10000
R1(config-router)# interface S0/0/1
R1(config-if)# bandwidth 64

R2(config)# router ospf 10
R2(config-router)# router-id 2.2.2.2
R2(config-router)# network 172.16.2.0 0.0.0.255 area 0
R2(config-router)# network 172.16.3.0 0.0.0.3 area 0
R2(config-router)# network 192.168.10.8 0.0.0.3 area 0
R2(config-router)# passive-interface g0/0
R2(config-router)# auto-cost reference-bandwidth 10000
R2(config-router)# interface S0/0/1
R2(config-if)# bandwidth 1024

R3(config)# router ospf 10
R3(config-router)# router-id 3.3.3.3
R3(config-router)# network 192.168.1.0 0.0.0.255 area 0
R3(config-router)# network 192.168.10.4 0.0.0.3 area 0
R3(config-router)# network 192.168.10.8 0.0.0.3 area 0
R3(config-router)# passive-interface g0/0
R3(config-router)# auto-cost reference-bandwidth 10000
R3(config-router)# interface S0/0/0
R3(config-if)# bandwidth 64
R3(config-if)# interface S0/0/1
R3(config-if)# bandwidth 1024

 

Modifier OSPFv2

Cette section passe en revue les concepts et les commandes pour redistribuer une route par défaut, régler les interfaces OSPF et manipuler le processus d’élection du routeurdésigné /routeur de sauvegarde désigné (DR/BDR).

Redistribution d’une route par défaut

Dans la figure A, R1 a un lien avec Internet qui fait de R1 un routeur de frontière de système autonome (ASBR).

Nous configurons donc une route par défaut vers Internet et redistribuons la route statique par défaut à R2 et R3 avec la commande default-information originate , comme dans l’exemple A.

Exemple B – Configuration de route statique par défaut d’un ASBR

R1(config)# ip route 0.0.0.0 0.0.0.0 Serial 0/1/0
R1(config)# router ospf 10
R1(config-router)# default-information originate

 

R2 et R3 devraient maintenant avoir des routes par défaut identifiées avec le code O*E2, comme dans l’exemple B.

Exemple C – Routes OSPF R2 et R3 avec Route par défaut

R2# show ip route ospf
     172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
O         172.16.1.0 [110/6477] via 172.16.3.1, 00:02:45, Serial0/0/0
O    192.168.1.0 [110/6486] via 192.168.10.10, 00:00:55, Serial0/0/1
     192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
O         192.168.10.4 [110/12952] via 192.168.10.10, 00:00:55, Serial0/0/1
O*E2 0.0.0.0/0 [110/1] via 172.16.3.1, 00:00:09, Serial0/0/0

R3# show ip route ospf
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
O         172.16.1.0 [110/6477] via 192.168.10.5, 00:26:01, Serial0/0/0
O         172.16.2.0 [110/6486] via 192.168.10.9, 00:26:01, Serial0/0/1
O         172.16.3.0 [110/6540] via 192.168.10.5, 00:26:01, Serial0/0/0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.9, 00:01:19, Serial0/0/1

 

Modifier les intervalles Hello et Dead

L’intervalle hello par défaut sur les réseaux multi-accès et point à point est de 10 secondes. Par défaut, les réseaux multi-accès non diffusant (NBMA) ont un intervalle hello de 30 secondes. L’intervalle dead par défaut est quatre fois plus long que l’intervalle hello.

Il peut être souhaitable de changer les minuteries OSPF pour que les routeurs détectent les pannes de réseau en moins de temps. Cela augmente le trafic, mais parfois le besoin d’une convergence rapide est plus important que la quantité du trafic supplémentaire.

Vous pouvez modifier l’OSPF hello et les intervalles dead manuellement en utilisant les commandes d’interface suivantes :

Router(config-if)# ip ospf hello-interval seconds
Router(config-if)# ip ospf dead-interval seconds

Bien que l’intervalle dead par défaut soit quatre fois supérieur à l’intervalle hello et qu’il ne soit pas nécessaire de le configurer explicitement, il est recommandé de documenter le nouvel intervalle dead dans la configuration.

L’exemple D montre l’intervalle Hello et l’intervalle Dead modifiés à 5 secondes et 20 secondes, respectivement, sur l’interface Serial 0/0/0 pour R1.

Exemple D – Modification des intervalles Hello et Dead sur R1

R1(config)# interface serial 0/0/0
R1(config-if)# ip ospf hello-interval 5
R1(config-if)# ip ospf dead-interval 20
R1(config-if)# end

Rappelez-vous que, contrairement au protocole EIGRP (Enhanced Interior Gateway Routing Protocol), l’OSPF hello et les intervalles dead doivent être équivalents entre voisins. Par conséquent, R2 doit être configuré avec les mêmes intervalles.

Types de réseaux OSPF

OSPF définit cinq types de réseaux :

Point à point : Deux routeurs interconnectés par une liaison commune. Aucun autre routeur n’est sur le lien. C’est souvent la configuration dans les liens WAN.

Diffusion multi-accès : Plusieurs routeurs interconnectés sur un réseau Ethernet.

NBMA : Routeurs multiples interconnectés dans un réseau qui ne permet pas la diffusion, comme Frame Relay par exemple.

Point à multipoint : Plusieurs routeurs interconnectés dans une topologie en étoile sur un réseau NBMA. Souvent utilisé pour relier les sites des succursales (spokes) à un site central (hub).

Liens virtuels : Réseau OSPF spécial utilisé pour interconnecter des zones OSPF distantes à la zone du réseau fédérateur.

Les réseaux multi-accès posent deux défis à OSPF en ce qui concerne l’inondation des LSAs:

Création de multiples adjacences: Les réseaux Ethernet peuvent potentiellement interconnecter de nombreux routeurs OSPF sur une liaison commune. En utilisant la formule n(n – 1) / 2, où n est égal au nombre de routeurs, 5 routeurs auraient besoin de 10 adjacences voisines séparées ; 10 routeurs auraient besoin de 45.

Inondations massives des LSAs: Les routeurs d’état de liaison inondent leurs paquets d’état de liaison lorsque OSPF est initialisé ou lorsque la topologie change. Cette inondation peut devenir excessive sans qu’il y ait un mécanisme pour réduire le nombre de relations d’adjacence.

Élection DR/BDR

La solution pour gérer le nombre d’adjacences et l’inondation des LSA sur un réseau multi-accès est le routeur désigné (DR). Pour réduire la quantité de trafic OSPF sur les réseaux multi-accès, OSPF choisit un DR et un DR de secours (BDR).

Le DR est responsable de la mise à jour de tous les autres routeurs OSPF lorsqu’un changement se produit dans le réseau multi-accès. Le BDR surveille le DR et prend la relève en tant que DR si le DR actuel échoue.

Les critères suivants sont utilisés pour choisir le DR et le BDR :

1. Le DR est le routeur avec la priorité d’interface OSPF la plus élevée.

2. Le BDR est le routeur ayant la deuxième priorité d’interface OSPF la plus élevée.

3. Si les priorités de l’interface OSPF sont identiques, l’ID de routeur le plus élevé brisera l’égalité.

Lorsque le DR est élu, il reste le DR jusqu’à ce que l’une des conditions suivantes se produise :

  • Le DR échoue.
  • Le processus OSPF sur le DR échoue.
  • L’interface multi-accès sur la DR échoue.

Si le DR échoue, le BDR assume le rôle de DR, et une élection a lieu pour choisir un nouveau BDR.

Si un nouveau routeur entre dans le réseau après que le DR et le BDR ont été élus, il ne deviendra pas le DR ou le BDR même s’il a une priorité d’interface OSPF ou un ID de routeur supérieur au DR ou BDR actuel.

Le nouveau routeur peut être élu BDR si le DR ou BDR actuel échoue. Si le DR actuel échoue, le BDR devient le DR, et le nouveau routeur peut être élu le nouveau BDR.

Sans configuration supplémentaire, vous pouvez contrôler les routeurs qui remportent les élections DR et BDR en procédant de l’une des manières suivantes :

  • Démarrez d’abord le DR, puis le BDR, puis tous les autres routeurs.
  • Fermer l’interface sur tous les routeurs, suivi d’un no shutdown sur le DR, puis sur le BDR, et enfin sur tous les autres routeurs.

La façon recommandée pour contrôler les élections DR/BDR, cependant, est de changer la priorité de l’interface.

Contrôle de l’élection DR/BDR

Parce que le DR devient le point central pour la collecte et la distribution des LSA dans un réseau multi-accès, ce routeur doit avoir une capacité CPU et mémoire suffisante pour assumer cette responsabilité.

Au lieu de se fier à l’ID du routeur pour décider quels routeurs sont élus le DR et le BDR, il est préférable de contrôler l’élection de ces routeurs avec la commande ip ospf priority interface :

Router(config-if)# ip ospf priority {0 - 255}

La valeur de priorité par défaut est 1 pour toutes les interfaces de routeur, ce qui signifie que l’ID de routeur détermine le DR et le BDR.

Si vous changez la valeur par défaut de 1 à une valeur supérieure, cependant, le routeur ayant la priorité la plus élevée devient le DR et le routeur ayant la seconde priorité la plus élevée devient le BDR. Une valeur de 0 rend le routeur inéligible pour devenir un DR ou un BDR.

Tous les routeurs de la Figure B ont démarré en même temps avec une configuration OSPF complète. Dans une telle situation, R3 est élu DR, et R2 est élu BDR sur la base des ID de routeur les plus élevés, comme vous pouvez le voir dans la sortie pour la table des voisins sur R1 de l’exemple E.

Figure B - Topologie multi-accès
Figure B – Topologie multi-accès

 

Exemple E – Vérification du DR et du BDR

R1# show ip ospf neighbor
Neighbor ID 	Pri 	State 		Dead Time 	Address 	Interface
2.2.2.2 	1 	FULL/BDR 	00:00:32 	192.168.1.2 	GigabitEthernet0/0
3.3.3.3 	1 	FULL/DR 	00:00:38 	192.168.1.3 	GigabitEthernet0/0
R1#

Supposons que R1 est le meilleur candidat pour être DR et que R2 devrait être BDR. L’exemple F montre un moyen de contrôler l’élection DR/BDR dans la topologie de la figure B.

Exemple F – Modification de la priorité de l’interface OSPF

R1(config)# interface gigabitethernet 0/0
R1(config-if)# ip ospf priority 200
R2(config)# interface gigabitethernet 0/0
R2(config-if)# ip ospf priority 100

 

Notez que nous avons changé les deux routeurs. Bien que R2 soit le BDR sans rien faire, il perdrait ce rôle au profit de R3 si nous n’avions pas configuré la priorité de R2 comme étant supérieure à la priorité par défaut.

Avant que R1 puisse devenir DR, le processus OSPF doit redémarrer. Ceci peut être fait en fermant les interfaces ou en entrant simplement la commande clear ip ospf process en mode EXEC privilégié, comme dans l’exemple G. La table des voisins sur R3 montre que R1 est maintenant le DR et R2 est le BDR.

Exemple G – Redémarrage du processus OSPF et vérification des nouveaux DR et BDR

R1# clear ip ospf process
Reset ALL OSPF processes? [no]: y
R1#

R2# clear ip ospf process
Reset ALL OSPF processes? [no]: y
R2#

R3# clear ip ospf process
Reset ALL OSPF processes? [no]: y
R3#

R3# show ip ospf neighbor
Neighbor ID 	Pri 	State 		Dead Time 	Address 	Interface
2.2.2.2 	100 	FULL/BDR 	00:00:38 	192.168.1.2 	GigabitEthernet0/0
1.1.1.1 	200 	FULL/DR 	00:00:30 	192.168.1.1 	GigabitEthernet0/0
R3#

 

Exemple de configuration OSPFv3

Pour améliorer OSPFv3, nous utilisons la topologie de la Figure C et le schéma d’adressage du Tableau B.

Figure C - Topologie de configuration OSPFv3
Figure C – Topologie de configuration OSPFv3

 

Tableau B – Schéma d’adressage pour OSPFv3

Appareil
InterfaceAdresse IPv6/préfixe
R1G0/02001:DB8:CAFE:1::1/64
S0/0/02001:DB8:CAFE:A001::2/64
Link-localFE80::1
Router ID1.1.1.1
R2G0/02001:DB8:CAFE:2::1/64
S0/0/02001:DB8:CAFE:A001::1/64
S0/0/12001:DB8:CAFE:A002::1/64
S0/1/02001:DB8:FEED:1::2/64
Link-localFE80::2
Router ID2.2.2.2
R3G0/02001:DB8:CAFE:3::1/64
S0/0/12001:DB8:CAFE:A002::2/64
Link-localFE80::3
Router ID3.3.3.3

L’exemple H montre les commandes de configuration de R2 pour activer IPv6 et OSPFv3 sur toutes les interfaces. Les commandes sont les mêmes pour R1 et R3.

Exemple H – Activer IPv6 et OSPFv3 sur R2

R2(config)# ipv6 unicast-routing
R2(config)# ipv6 router ospf 10
R2(config-rtr)# router-id 2.2.2.2
R2(config-rtr)# auto-cost reference-bandwidth 1000
R2(config-rtr)# interface g0/0
R2(config-if)# ipv6 add 2001:db8:cafe:2::1/64
R2(config-if)# ipv6 add fe80::1 l
R2(config-if)# ipv6 ospf 10 area 0
R2(config-if)# interface s0/0/0
R2(config-if)# ipv6 add 2001:db8:cafe:a001::1/64
R2(config-if)# ipv6 add fe80::2 link-local
R2(config-if)# ipv6 ospf 10 area 0
R2(config-if)# interface s0/0/1
R2(config-if)# ipv6 add 2001:db8:cafe:a002::1/64
R2(config-if)# ipv6 add fe80::2 link-local
R2(config-if)# ipv6 ospf 10 area 0
R2(config-if)# interface s0/1/0
R2(config-if)# ipv6 add 2001:db8:feed:1::2/64
R2(config-if)# ipv6 add fe80::2 link-local
R2(config-if)# end

R2# show ipv6 ospf neighbor

Neighbor ID 	Pri 	State 	Dead Time 	Interface ID 	Interface
3.3.3.3 	0 	FULL/-  00:00:38 	4 	Serial0/0/1
1.1.1.1 	0 	FULL/- 	00:00:33 	3 	Serial0/0/0

R2# show ipv6 route ospf
IPv6 Routing Table - 11 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
  U - Per-user Static route, M - MIPv6
  I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
  O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
  ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
  D - EIGRP, EX - EIGRP external
O 	2001:DB8:CAFE:1::/64 [110/65]
    via FE80::1, Serial0/0/0
O 	2001:DB8:CAFE:3::/64 [110/65]
    via FE80::3, Serial0/0/1
R2#

 

Les deux commandes montrent les voisins ipv6 ospf neighbors et show ipv6 route ospf vérifient que R2 a établi des adjacences avec R1 et R3 et ont appris les routes nécessaires. Vous allez configurer le lien vers Internet dans la section suivante.

Modifier OSPFv3

Comme avec OSPFv2, vous pouvez configurer OSPFv3 pour propager une route par défaut et ajuster avec précision les interfaces.

Propagation de route par défaut

Le processus de propagation d’une route par défaut dans OSPFv3 est le même que pour OSPFv2.

Comme vous pouvez le voir dans la configuration de R2 dans l’exemple I, vous configurez la route par défaut et utilisez ensuite la commande default-information originate dans le mode de configuration routeur pour propager la route aux voisins OSPF.

Exemple I – Propagation de route par défaut dans OSPFv3

R2(config)# ipv6 route ::/0 serial 0/1/0
R2(config)# ipv6 router ospf 10
R2(config-rtr)# default-information originate
R2(config-rtr)# end
R2#

Comme le montre l’exemple J, R1 et R3 ont tous deux une route par défaut indiquée par le OE2 dans la table de routage.

Exemple J – Route par défaut propagée à R1 et R3

R1# show ipv6 route ospf | begin OE2 :
OE2 	::/0 [110/1], tag 1
    via FE80::2, Serial0/0/0
O	2001:DB8:CAFE:2::/64 [110/65]
    via FE80::2, Serial0/0/0
O 	2001:DB8:CAFE:3::/64 [110/129]
    via FE80::2, Serial0/0/0
O 	2001:DB8:CAFE:A002::/64 [110/128]
    via FE80::2, Serial0/0/0
R1#

R3# show ipv6 route ospf | begin OE2 :
OE2 	::/0 [110/1], tag 1
    via FE80::2, Serial0/0/1
O 	2001:DB8:CAFE:1::/64 [110/129]
    via FE80::2, Serial0/0/1
O 	2001:DB8:CAFE:2::/64 [110/65]
    via FE80::2, Serial0/0/1
O 	2001:DB8:CAFE:A001::/64 [110/128]
    via FE80::2, Serial0/0/1
R3#

 

Modification des timers

Pour modifier les timers OSPFv3, utilisez les mêmes commandes que pour OSPFv2, mais changez ip en ipv6, comme dans l’exemple K.

Exemple K – Configuration des intervalles Hello et Dead dans OSPFv3

R2(config)# interface s0/0/0
R2(config-if)# ipv6 ospf hello-interval 5
R2(config-if)# ipv6 ospf dead-interval 20
R2(config-if)# end
R2#
%OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on Serial0/0/0 from FULL to DOWN,
  Neighbor Down: Dead timer expired
%OSPFv3-5-ADJCHG: Process 10, Nbr 1.1.1.1 on
  Neighbor Down: Interface down or detached

 

R2 perd son adjacence avec R1. Pour rétablir la relation d’adjacence, vous devez configurer R1 avec les mêmes timers, comme dans l’exemple L.

Exemple L – Configuration des timers sur R1 pour qu’ils correspondent à ceux de R2

R1(config)# interface s0/0/0
R1(config-if)# ipv6 ospf hello-interval 5
R1(config-if)# ipv6 ospf dead-interval 20
R1(config-if)# end
%OSPFv3-5-ADJCHG: Process 10, Nbr 2.2.2.2 on Serial0/0/0 from LOADING to FULL,
  Loading Done
R1#

 

Dépannage OSPF

Comprendre le fonctionnement de l’OSPF est fondamental pour dépanner tout problème d’OSPF. La clé de cette compréhension est le concept des états que OSPF traverse pendant la creation de la relation d’adjacence avec un voisin.

États du protocole OSPF

La Figure D énumère les états OSPF. Lors du dépannage des voisins OSPF, sachez que les états FULL et 2WAY sont normaux. Tous les autres États sont transitoires.

Figure D - Transitions à travers les États OSPF
Figure D – Transitions à travers les États OSPF

Relation d’adjacence OSPF

L’absence d’adjacence est un problème courant dans le dépannage OSPF car les deux voisins OSPF doivent se mettre d’accord sur plusieurs réglages. Les adjacences OSPF ne se forment pas si un ou plusieurs des éléments suivants ne correspondent pas :

  • Les interfaces ne sont pas sur le même réseau.
  • Les types de réseau OSPF ne correspondent pas.
  • Les timers OSPF hello ou dead ne correspondent pas.
  • L’interface avec le voisin est incorrectement configurée comme passive.
  • Une commande network OSPF est manquante ou incorrecte.
  • L’authentification est mal configurée.

Commandes de dépannage OSPF

Lorsque vous essayez d’isoler un problème de routage OSPFv2, les commandes suivantes sont utiles :

show ip protocols: Vérifie les informations vitales de configuration OSPF, y compris l’ID de processus OSPF, l’ID de routeur, les réseaux que le routeur annonce, les voisins dont ils reçoit les mises à jour et la distance administrative par défaut, qui est 110 pour OSPF.

show ip ospf neighbor: Vérifie que le routeur a formé une relation d’adjacence avec ses routeurs voisins.

show ip ospf interface: Affiche les paramètres OSPF configurés sur une interface, tels que l’ID de processus OSPF, la zone, le coût et les intervalles de temps.

show ip ospf: Examine l’ID de processus OSPF et l’ID de routeur. Cette commande affiche également les informations de la zone OSPF et la dernière fois que l’algorithme SPF a été calculé.

show ip route ospf: Affiche uniquement les routes apprises par OSPF dans la table de routage.

clear ip ospf process: Réinitialise les adjacences de voisinage OSPFv2.

La figure E illustre une méthode d’utilisation systématique de ces commandes.

Figure E - Méthode systématique de dépannage OSPFv2
Figure E – Méthode systématique de dépannage OSPFv2

Vous pouvez utiliser le même processus pour dépanner les implémentations OSPFv3. Remplacez simplement l’ip par ipv6 dans la liste des commandes show spécifiques à OSPF :

  • show ipv6 protocols
  • show ipv6 ospf neighbor
  • show ipv6 ospf interface
  • show ipv6 ospf
  • show ipv6 route ospf
  • clear ipv6 ospf process

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image