Fonctionnement, configuration et dépannage de RIPv1/RIPv2

Les protocoles de routage spécifient une méthode pour envoyer et recevoir dynamiquement des mises à jour de routage entre les routeurs. Le protocole de routage le plus simple à configurer et à comprendre est le Routing Information Protocol (RIP).

Le RIP est rarement utilisé dans les réseaux aujourd’hui, mais sa simplicité en fait un outil précieux pour les étudiants qui veulent comprendre le fonctionnement de base des protocoles de routage.

En fait, le RIP est le seul protocole de routage couvert par l’examen du CCENT/ICND1. Le RIP a été choisi pour cet examen parce qu’un protocole de routage était nécessaire pour aborder les autres sujets d’examen liés à l’interprétation et à la description de la table de routage.

L’OSPF et l’EIGRP sont plus complexes en fonctionnement que le RIP, ils sont donc réservés à l’examen CCNA/ICND2.

Aujourd’hui, nous examinons le fonctionnement, la configuration, la vérification et le dépannage du RIP. Nous utilisons également RIP pour examiner comment une table de routage est construite et examiner les composants d’une table de routage.

Concepts du RIP

Comme RIPv2 est une amélioration de RIPv1, vous devriez pouvoir comparer et différencier les concepts et les configurations des deux versions. Examinons d’abord brièvement RIPv1.

Format de message RIPv1

RIPv1 est un protocole de routage à vecteur de distance classique pour IPv4. Il utilise le nombre de sauts comme seule métrique pour la sélection du chemin ; un nombre de sauts supérieur à 15 est considéré comme injoignable.

Les messages de routage RIPv1 sont encapsulés dans un segment UDP en utilisant le numéro de port 520 et sont diffusés toutes les 30 secondes. La Figure A montre l’encapsulation du message RIPv1 depuis la couche de liaison de données jusqu’au message RIPv1 inclus.

Figure A - Encapsulation des messages RIPv1
Figure A – Encapsulation des messages RIPv1

Fonctionnement du RIPv1
Notez dans le message RIP que RIP utilise deux types de message spécifiés dans le champ Commande. La commande 1 est un message de demande et la commande 2 est un message de réponse.

Chaque interface configurée en RIP envoie un message de demande au démarrage, demandant à tous les voisins RIP d’envoyer leurs tables de routage complètes.

Les voisins compatibles RIP envoient un message de réponse. Lorsque le routeur demandeur reçoit les réponses, il évalue chaque entrée de route. Si une entrée de route est nouvelle, le routeur de réception installe la route dans la table de routage.

Si la route est déjà dans la table, l’entrée existante est remplacée si la nouvelle entrée a un meilleur nombre de sauts.

Le routeur de démarrage envoie alors une mise à jour déclenchée de toutes les interfaces compatibles RIP contenant sa propre table de routage afin que les voisins RIP puissent apprendre de nouvelles routes.

RIPv1 n’envoie pas d’informations de masque de sous-réseau dans la mise à jour. Par conséquent, un routeur utilise soit le masque de sous-réseau configuré sur une interface locale, soit le masque de sous-réseau par défaut en fonction de la classe d’adresses.

En raison de cette limitation, les réseaux RIPv1 ne peuvent pas être discontigus, ni mettre en œuvre le VLSM ou le sur-réseautage.

RIP a une distance administrative par défaut de 120. Comparé aux autres protocoles de passerelle intérieure, le RIP est le protocole de routage le moins préféré.

Configuration RIPv1

La Figure B et le Tableau A montrent la topologie RIPv1 du premier scénario et le schéma d’adressage que nous utilisons pour examiner la configuration et la vérification RIPv1.

Figure B - Topologie RIPv1 : Scénario A
Figure B – Topologie RIPv1: Scénario A

Tableau A – Schéma d’adressage du scénario A

AppareilInterfaceAdresse IPMasque de sous-réseau
R1G0/0192.168.1.1255.255.255.0
S0/0/0192.168.2.1255.255.255.0
R2G0/0192.168.3.1255.255.255.0
S0/0/0192.168.2.2255.255.255.0
S0/0/1192.168.4.2255.255.255.0
R3
G0/0192.168.5.1255.255.255.0
S0/0/1192.168.4.1255.255.255.0

La figure B montre six réseaux en classe distincts, de sorte que chaque réseau doit être configuré individuellement. En supposant que les interfaces sur R1, R2 et R3 sont configurées et actives, l’exemple A montre la configuration RIPv1 pour les routeurs.

Exemple A – Configuration standard RIPv1 : Scénario A

R1(config)# router rip
R1(config-router)# network 192.168.1.0
R1(config-router)# network 192.168.2.0

R2(config)# router rip
R2(config-router)# network 192.168.2.0
R2(config-router)# network 192.168.3.0
R2(config-router)# network 192.168.4.0

R3(config)# router rip
R3(config-router)# network 192.168.4.0
R3(config-router)# network 192.168.5.0

 

Vérification et dépannage RIPv1

Les commandes de vérification suivantes, utilisées dans l’ordre, vérifient rapidement si le routage est opérationnel comme prévu.

  • show ip route
  • show ip protocols
  • debug ip rip

Si le routage ne fonctionne pas correctement, ces commandes vous aideront à localiser le problème de la manière la plus efficace.

Pour vérifier que le routage est opérationnel, commencez par la commande show ip route. Pour la topologie de la Figure B, toutes les routes doivent être dans la table de routage pour chaque routeur. L’exemple B montre la table de routage de R2.

Exemple B – Table de routage de R2 avec routes RIP installées

R2# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
<texte omité>

Gateway of last resort is not set

R 	192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:19, Serial0/0/0
  192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 		192.168.2.0/24 is directly connected, Serial0/0/0
L 		192.168.2.2/32 is directly connected, Serial0/0/0
  192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C 		192.168.3.0/24 is directly connected, GigabitEthernet0/0
L		 192.168.3.1/32 is directly connected, GigabitEthernet0/0
  192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C 		192.168.4.0/24 is directly connected, Serial0/0/1
L 		192.168.4.2/32 is directly connected, Serial0/0/1
R 	192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:13, Serial0/0/1
R2#

 

Pour mieux comprendre la sortie de la commande show ip route, concentrons-nous sur une route RIP apprise par R2 et interprétons la sortie indiquée dans la table de routage :

R 192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:23, Serial0/0/1

Le tableau B énumère et décrit chaque partie de la sortie.

Tableau B – Interprétation d’une route RIP 

SortieDescription
RIdentifie la source de la route en tant que RIP.
192.168.5.0Indique l'adresse du réseau distant.
/24Indique le masque de sous-réseau utilisé pour ce réseau.
[120/1]Affiche la distance administrative (120) et la métrique (1 saut).
via 192.168.4.1,Spécifie l'adresse du routeur de saut suivant (R3) vers lequel le trafic vers le réseau distant sera envoyé.
00:00:23,Indique le temps écoulé depuis la mise à jour de la route (ici, 23 secondes). Une autre mise à jour est attendue dans 7 secondes.
Serial0/0/1Indique l'interface locale via laquelle le réseau distant peut être atteint.

Si la table de routage manque une ou plusieurs routes attendues, utilisez d’abord la commande show ip protocols du routeur local pour vous assurer que RIP est bien configuré et fonctionne correctement.

Cette commande affiche le protocole de routage actuellement configuré sur le routeur. Vous pouvez consulter la sortie pour vérifier la plupart des paramètres RIP et confirmer ce qui suit :

  • Le routage RIP est configuré.
  • Les interfaces correctes envoient et reçoivent les mises à jour RIP.
  • Le routeur annonce les réseaux corrects.
  • Les voisins RIP envoient des mises à jour.

La figure C montre la sortie de la commande show ip protocols, avec des chiffres pour chaque partie de la sortie. Les descriptions qui suivent la figure correspondent aux chiffres de la figure.

Figure C - Interprétation de la sortie de show ip protocols
Figure C – Interprétation de la sortie de show ip protocols

1. La première ligne de sortie vérifie que le routage RIP est configuré et fonctionne sur R2.

2. Les informations de filtrage et de redistribution affichées ici sont un sujet de niveau CCNP.

3. Ces timers indiquent quand la prochaine série de mises à jour sera envoyée à partir de ce routeur dans 23 secondes, dans l’exemple.

4. Ce bloc d’édition contient des informations sur la version de RIP actuellement configurée et sur les interfaces qui participent aux mises à jour RIP. Notez que le routeur envoie les mises à jour de la version 1 mais qu’il peut recevoir à la fois la version 1 et la version 2.

5. Cette partie de la sortie montre que R2 est actuellement en train de réduire à la limite du réseau classful et, par défaut, utilisera jusqu’à quatre routes à coût égal pour équilibrer le trafic.

6. Les réseaux classful configurés avec la commande network sont listés ci-dessous. Si R2 a une interface active pour le réseau configuré, R2 inclura le réseau dans ses mises à jour RIP.

7. Ici, les voisins RIP sont listés comme sources d’informations de routage. Gateway est l’adresse IP du prochain saut du voisin qui envoie les mises à jour à R2. La distance est l’AD que R2 utilise pour les mises à jour envoyées par ce voisin.

La plupart des erreurs de configuration RIP impliquent une configuration incorrecte des instructions network, une configuration manquante des instructions network ou encore une configuration de sous-réseaux discontigus dans un environnement clasful.

Comme le montre la Figure D, debug ip rip aide à trouver des problèmes avec les mises à jour du RIP.

Figure D - Interprétation de la sortie de debug ip rip
Figure D – Interprétation de la sortie de debug ip rip

Cette commande affiche les mises à jour du routage RIP au fur et à mesure qu’elles sont envoyées et reçues, ce qui vous donne la possibilité de suivre les sources potentielles d’un problème d’acheminement. La liste suivante correspond aux chiffres de la figure D.

1. Vous voyez une mise à jour provenant de R1 sur l’interface Serial0/0/0. Notez que R1 n’envoie qu’une seule route vers le réseau 192.168.1.0. Aucune autre route n’est envoyée car cela violerait la règle du split horizon. R1 n’est pas autorisé à faire connaître à R2 les réseaux que R2 a déjà envoyés à R1.

2. La prochaine mise à jour reçue vient de R3. Encore une fois, à cause de la règle du split horizon, R3 n’envoie qu’une seule route : le réseau 192.168.5.0.

3. R2 envoie ses propres mises à jour. Tout d’abord, R2 n’a pas d’interfaces passives configurées. Par conséquent, R2 construit une mise à jour pour envoyer l’interface GigabitEthernet 0/0 même s’il n’y a aucun routeur pour recevoir la mise à jour. La mise à jour inclut toute la table de routage à l’exception du réseau 192.168.3.0, qui est attaché à GigabitEthernet 0/0.

4. Ensuite, R2 construit une mise à jour à envoyer à R3. Trois routes sont incluses. R2 ne fait pas connaître la part du réseau que partagent R2 et R3, pas plus qu’il ne fait connaître le réseau 192.168.5.0 en raison du split horizon.

5. Enfin, R2 construit une mise à jour à envoyer à R1. Trois routes sont incluses. R2 n’annonce pas le réseau que R2 et R1 partagent, pas plus qu’il n’annonce le réseau 192.168.1.0 à cause du split horizon.

6. Pour arrêter la surveillance des mises à jour du RIP sur R2, entrez la commande no debug ip rip ou undebug all, comme sur la Figure D.

Interfaces passives

Dans la topologie de la Figure B, notez qu’il n’y a aucune raison d’envoyer les mises à jour via les interfaces GigabitEthernet de chaque routeur. Par conséquent, vous devez les configurer en tant qu’interfaces passives pour deux raisons :

  • Améliorer la sécurité en empêchant quelqu’un connecté à l’un des réseaux locaux d’intercepter, d’inspecter et éventuellement de modifier les mises à jour RIP.
  • Améliorer l’efficacité du traitement des routeurs

Utilisez la commande passive-interface pour arrêter d’envoyer des mises à jour RIP sur les interfaces GigabitEthernet, comme dans l’exemple C pour R2. La commande show ip protocols permet ensuite de vérifier la configuration de l’interface passive.

Exemple C – Désactivation des mises à jour avec la commande passive-interface

R2(config)# router rip
R2(config-router)# passive-interface GigabitEthernet 0/0
R2(config-router)# do show ip protocols
*** IP Routing is NSF aware ***
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 19 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface 	Send 	Recv 	Triggered RIP 	Key-chain
    Serial0/0/0 	1 	1 2
    Serial0/0/1 	1 	1 2
    Interface Send Recv Triggered RIP Key-chain
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.2.0
    192.168.3.0
    192.168.4.0
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway 	Distance 	Last Update
    192.168.2.1 	120 		00:00:13
    192.168.4.1 	120 		00:00:05
  Distance: (default is 120)

Notez que l’interface GigabitEthernet n’est plus listée sous Interface, mais est listée sous une nouvelle section appelée Interface(s) passive(s).

Notez également que le réseau 192.168.3.0 est toujours répertorié sous Routage pour les réseaux, ce qui signifie que ce réseau est toujours inclus comme une entrée de route dans les mises à jour RIP envoyées à R1 et R3.

Tous les protocoles de routage prennent en charge la commande passive-interface.

Récapitulation automatique

Le protocole RIP se résume automatiquement à la limite du réseau classful. La Figure E et le Tableau C montrent la topologie RIPv1 pour le scénario B et le schéma d’adressage que nous utilisons pour le reste de cette article sur RIPv1 et RIPv2.

Figure E - Topologie RIPv1 : Scénario B
Figure E – Topologie RIPv1: Scénario B

Tableau C – Schéma d’adressage RIPv1: Scénario B

AppareilInterfaceAdresse IPMasque de sous-réseau
R1G0/0172.30.1.1255.255.255.0
S0/0/0172.30.2.1255.255.255.0
R2G0/0172.30.3.1255.255.255.0
S0/0/0172.30.2.2255.255.255.0
S0/0/1192.168.4.9255.255.255.252
R3G0/0192.168.5.1255.255.255.0
S0/0/1192.168.4.10255.255.255.252

En supposant que toutes les interfaces sont configurées et activées, l’exemple D montre la configuration RIP de R1, R2, et R3.

Exemple D – Configuration standard RIPv1 : Scénario B

R1(config)# router rip
R1(config-router)# network 172.30.0.0

R2(config)# router rip
R2(config-router)# network 172.30.0.0
R2(config-router)# network 192.168.4.0

R3(config)# router rip
R3(config-router)# network 192.168.4.0
R3(config-router)# network 192.168.5.0

Notez que, dans la configuration RIP pour tous les routeurs, l’adresse réseau classful a été entrée à la place de chaque sous-réseau.

Si nous avions saisi les sous-réseaux à la place, Cisco IOS les aurait résumés à l’adresse réseau de classe. En effet, un routeur RIP utilise le masque de sous-réseau configuré sur une interface locale ou applique le masque de sous-réseau par défaut en fonction de la classe d’adresses.

Par conséquent, RIPv1 ne peut pas prendre en charge les sous-réseaux, les super-réseaux ou les schémas d’adressage VLSM discontigus. L’exemple E montre ce que R2 envoie dans ses mises à jour à R1 et R3.

Exemple E – Mises à jour RIPv1 de R2

R2# debug ip rip
RIP protocol debugging is on
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (172.30.2.2)
RIP: build update entries
  subnet 172.30.3.0 metric 1
  network 192.168.4.0 metric 1
  network 192.168.5.0 metric 2
RIP: sending v1 update to 255.255.255.255 via Serial0/0/1 (192.168.4.9)
RIP: build update entries
  network 172.30.0.0 metric 1

Lorsque R2 envoie des mises à jour à R1, il envoie le réseau 172.30.3.0 parce que l’interface série 0/0/0 utilise un masque /24 pour le réseau 172.30.2.0.

Cependant, il résume le sous-réseau 192.168.4.0 à 192.168.4.0 avant d’envoyer la mise à jour à R1 parce que R1 applique le masque de classe par défaut à la mise à jour du routing. R2 est un routeur de frontière pour le réseau 192.168.4.0.

Pour sa mise à jour vers R3, R2 résume les sous-réseaux 172.30.1.0, 172.30.2.2.0, et 172.30.3.0 au réseau de classe 172.30.0.0 parce que R2 est le routeur de frontière pour le réseau 172.30.0.0 et suppose que R3 n’a aucun autre moyen pour atteindre le réseau 172.30.0.0.

Routage par défaut et RIPv1

En utilisant le même schéma d’adressage du Tableau C, modifions la topologie comme illustré dans la Figure F pour que R2 et R3 utilisent un routage statique et par défaut.

Figure F - Topologie RIPv1 : Scénario B (Modifié)
Figure F – Topologie RIPv1 : Scénario B (Modifié)

L’exemple F montre les modifications de configuration apportées à R2 et R3. R3 fournit un service à Internet, donc R2 utilisera une route par défaut pour envoyer tout le trafic pour des destinations inconnues à R3.

R3 utilisera une route sommaire pour envoyer tout le trafic vers les sous-réseaux de 172.30.0.0.

Exemple F – Modifications apportées à la configuration de R2 et R3

R2(config)# router rip
R2(config-router)# no network 192.168.4.0
R2(config-router)# exit
R2(config)# ip route 0.0.0.0 0.0.0.0 serial 0/0/1

R3(config)# no router rip
R3(config)# ip route 172.30.0.0 255.255.252.0 serial 0/0/1

Nous pourrions configurer R1 avec une route par défaut pointant vers R2. Une solution meilleure et plus évolutive, cependant, est d’utiliser la commande default-information originate pour que R2 propage sa route par défaut à R1 dans ses mises à jour de routage RIP.

R2(config)# router rip
R2(config-router)# default-information originate

Comme le montre l’exemple G, R1 a maintenant une route RIP marquée d’un astérisque (*), indiquant que cette route est une passerelle par défaut.

Exemple G – Vérification de la propagation de la route par défaut

R1# show ip route
<text omité>
Gateway of last resort is 172.30.2.2 to network 0.0.0.0

R* 0.0.0.0/0 [120/1] via 172.30.2.2, 00:00:00, Serial0/0/0
  172.30.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 		172.30.1.0/24 is directly connected, GigabitEthernet0/0
L 		172.30.1.1/32 is directly connected, GigabitEthernet0/0
C 		172.30.2.0/24 is directly connected, Serial0/0/0
L 		172.30.2.1/32 is directly connected, Serial0/0/0
R 		172.30.3.0/24 [120/1] via 172.30.2.2, 00:00:00, Serial0/0/0
R1#

Configuration de RIPv2

Comme dans la version 1, RIPv2 est encapsulé dans un segment UDP utilisant le port 520 et peut transporter jusqu’à 25 routes. La Figure G montre les formats de message RIPv1 et RIPv2.

Figure G - Formats des messages RIPv1 et RIPv2
Figure G – Formats des messages RIPv1 et RIPv2

Aux fins d’examen, l’extension la plus importante fournie par RIPv2 est l’ajout du champ masque de sous-réseau, qui permet d’inclure un masque de 32 bits dans l’entrée de route RIP.

Par conséquent, le routeur de réception ne dépend plus du masque de sous-réseau de l’interface entrante ou du masque de classe pour déterminer le masque de sous-réseau d’une route.

Cela signifie que les trois principales limites de RIPv1, à savoir l’absence de conceptions réseau discontigues, de sur-réseautage et de support VLSM, ne sont plus un problème.

Par défaut, le processus RIP sur les routeurs Cisco envoie des messages RIPv1 mais peut recevoir RIPv1 et RIPv2. Vous pouvez le voir dans l’illustration de la sortie de show ip protocols précédemment dans l’exemple C.

Pour permettre l’envoi de messages RIPv2 dans notre topologie, entrez la commande version 2 en mode configuration routeur, comme dans l’exemple H.

Exemple H – Configuration de RIPv2

R2(config)# router rip
R2(config-router)# version 2
R2(config-router)# do show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 24 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface 		Send	Recv	 Triggered RIP 	Key-chain
    GigabitEthernet0/0	2	2
    Serial0/0/0 		2 	2
  Automatic network summarization is in effect
<texte omité>

Avec cette configuration, R2 n’enverra et ne recevra plus que des messages RIPv2. Cela signifie que nous devons configurer R1 avec la commande version 2 car R2 ignorera les messages RIPv1 envoyés par R1.

Désactivation de l’auto-compression

Notez cette ligne dans l’exemple H de la sortie de show ip protocols:

Automatic network summarization is in effect

Par défaut, RIPv2 résume automatiquement les réseaux à la frontière de classe comme dans RIPv1.

pour supporter les sous-réseaux dissociés et les VLSM, vous devez d’abord désactiver la compression automatique avec la commande no auto-summary sur tous les routeurs RIPv2 pour vous assurer que les sous-réseaux individuels sont envoyés dans les mises à jour de routage – pas l’adresse réseau classe réussie.

Vérification et dépannage RIPv2

Vous pouvez vérifier et dépanner RIPv2 de plusieurs façons. Vous pouvez utiliser plusieurs des mêmes commandes pour RIPv2 pour vérifier et dépanner d’autres protocoles de routage. Commencer par les bases est toujours le mieux :

  • S’assurer que tous les liens (interfaces) sont opérationnels.
  • Vérifier le câblage.
  • Assurez-vous d’avoir l’adresse IP et le masque de sous-réseau corrects sur chaque interface.
  • Supprimer toutes les commandes de configuration qui ne sont plus nécessaires ou qui ont été remplacées par d’autres commandes.

Les commandes à utiliser sont les mêmes que pour RIPv1, ainsi que votre utilisation standard de show ip interface brief, show run et ping. Mais considérez également les questions spécifiques suivantes du RIPv2 :

Version : Un bon point de départ pour commencer le dépannage d’un réseau qui exécute RIP est de vérifier que la commande version 2 est configurée sur tous les routeurs. RIPv1 ne prend pas en charge les sous-réseaux discontigus, les routes VLSM ou CIDR supernet.

Instructions network : Une autre source de problèmes peut être une configuration incorrecte ou des instructions réseau manquantes configurées avec la commande réseau. Rappelez-vous, la commande network fait deux choses :

  • Il permet au protocole de routage d’envoyer et de recevoir des mises à jour sur toute interface locale qui appartiennent à ce réseau.
  • Il inclut le réseau configuré dans ses mises à jour de routage vers ses routeurs voisins.
    Une instruction network manquante ou incorrecte entraîne des mises à jour de routage manquées, ainsi que des mises à jour de routage qui ne sont pas envoyées ou reçues sur une interface.

Compression automatique : Si des sous-réseaux spécifiques doivent être envoyés au lieu de routes simplement résumées, assurez-vous que la compression automatique a été désactivée avec la commande no auto-summary.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image