Configurer et dépanner DHCPv4 et DHCPv6

Configurer et dépanner DHCPv4 et DHCPv6

Imaginez que vous deviez configurer manuellement l’adressage IP pour chaque périphérique que vous souhaitez connecter au réseau. De plus, imaginez que vous devez saisir l’adresse IP de chaque site Web que vous voulez visiter.

Aujourd’hui, nous passons en revue les deux protocoles qui automatisent ces processus : Protocole DHCP (Dynamic Host Configuration Protocol) et DNS (Domain Name System).

DHCPv4

DHCPv4 permet à un hôte d’obtenir une adresse IP dynamiquement lorsqu’il se connecte au réseau. Le client DHCPv4 contacte le serveur DHCPv4 en envoyant une demande d’adresse IP.

Le serveur DHCPv4 choisit une adresse dans une plage d’adresses configurée appelée pool et l’affecte au client hôte pour une période donnée. La Figure A montre graphiquement comment un serveur DHCPv4 répond à une requête d’un client DHCPv4.

Lorsqu’un périphérique configuré avec DHCPv4 démarre ou se connecte au réseau, son client DHCPv4 diffuse un paquet DHCPDISCOVER pour identifier tous les serveurs DHCPv4 disponibles sur le réseau.

Un serveur DHCPv4 répond avec un DHCPOFFER, qui est un message d’offre de bail avec une adresse IP attribuée, un masque de sous-réseau, un serveur DNS et des informations par défaut sur la passerelle, ainsi que la durée du bail.

Le client DHCPv4 peut recevoir plusieurs paquets DHCPOFFER si le réseau local possède plusieurs serveurs DHCPv4. Le client choisit la première offre et diffuse un paquet DHCPREQUEST qui identifie un serveur explicite et l’offre de location qu’il accepte.

En supposant que l’adresse IP est toujours valide, le serveur sélectionné renvoie un message DHCPACK (accusé de réception) pour finaliser le bail.

Si l’offre n’est plus valable pour une raison quelconque, le serveur choisi répond au client par un message DHCPNAK (accusé de réception négatif). Une fois qu’il est loué, le client renouvelle avant l’expiration du bail par l’intermédiaire d’un autre DHCPREQUEST.

Si le client est mis hors tension ou retiré du réseau, l’adresse est retournée au pool pour être réutilisée.

Figure A - Attribution des informations d'adressage IP à l'aide de DHCPv4
Figure A – Attribution des informations d’adressage IP à l’aide de DHCPv4

Options de configuration DHCPv4

Un routeur Cisco peut être configuré pour traiter les requêtes DHCP de deux manières : comme serveur DHCP ou comme agent de relais DHCP.

Un routeur Cisco peut également être configuré comme client DHCP, demandant une adresse IPv4 à un serveur DHCP pour une ou plusieurs de ses interfaces. Toutes ces options peuvent être configurées en même temps sur le même appareil.

Par exemple, un routeur peut être le serveur DHCP d’un réseau local directement connecté tout en transférant les requêtes du serveur DHCP à un autre serveur DHCP pour d’autres réseaux locaux.

De plus, le routeur peut avoir une ou plusieurs de ses interfaces configurées pour demander l’adressage DHCP depuis un serveur distant.

Configuration d’un routeur en tant que serveur DHCPv4

Un routeur Cisco exécutant le logiciel Cisco IOS peut être configuré pour servir de serveur DHCPv4. Le serveur DHCPv4 Cisco IOS attribue et gère les adresses IPv4 des pools spécifiés d’adresses au sein du routeur aux clients DHCPv4.

Les étapes pour configurer un routeur comme serveur DHCPv4 sont les suivantes :

Étape 1. Utilisez la commande ip dhcp excluded-address low-address [high-address] pour identifier une adresse ou une plage d’adresses à exclure du pool DHCPv4. Par exemple :

R1(config)# ip dhcp excluded-address 192.168.10.1 192.168.10.9
R1(config)# ip dhcp excluded-address 192.168.10.254

 

Étape 2. Créez le pool DHCPv4 à l’aide de la commande ip dhcp pool pool-name, qui vous place en mode configuration DHCP :

R1(config)# ip dhcp pool LAN-POOL-10
R1(dhcp-config)#

 

Étape 3. Configurez les paramètres d’adressage IP que vous devez attribuer automatiquement aux clients demandeurs. Le Tableau A énumère les commandes requises.

Tableau A – Commandes requises pour configurer DHCPv4

Tâche requiseCommande
Définir le pool d'adressesnetwork network-number [mask | /prefix-length]
Définir le routeur ou la passerelle par défautdefault-router address [address2...address8]

Le Tableau B énumère quelques-unes des tâches optionnelles DHCPv4 les plus courantes.

Tableau B – Commandes de configuration DHCPv4 optionnelles

Tâche optionnelleCommande
Définir un serveur DNSdns-server address [address2...address8]
Définir le nom de domainedomain-name domain
Définir la durée du bail DHCPv4lease {days [hours] [minutes] | infinite}
Définir le serveur NetBIOS WINSnetbios-name-server address [address2...address8]

La Figure B montre un exemple de topologie DHCPv4.

Figure B - Topologie échantillon DHCPv4
Figure B – Topologie échantillon DHCPv4

L’exemple A montre les commandes DHCPv4 nécessaires et optionnelles pour configurer R1 comme serveur DHCPv4 pour les deux LAN.

Exemple A – Exemple de configuration DHCPv4

!Configure IP addresses that you want excluded from the DHCPv4 pool of addresses
R1(config)# ip dhcp excluded-address 192.168.10.1 192.168.10.9
R1(config)# ip dhcp excluded-address 192.168.10.254
R1(config)# ip dhcp excluded-address 192.168.11.1 192.168.11.9
R1(config)# ip dhcp excluded-address 192.168.11.254
!R1 needs two DHCPv4 pools for the two LANs. Each pool is configured with required
   and optional commands.
R1(config)# ip dhcp pool LAN-POOL-10
R1(dhcp-config)# network 192.168.10.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.10.1
R1(dhcp-config)# dns-server 192.168.50.195 209.165.202.158
R1(dhcp-config)# domain-name cisco.com
R1(dhcp-config)# lease 2
R1(dhcp-config)# netbios-name-server 192.168.10.254
R1(dhcp-config)# ip dhcp pool LAN-POOL-11
R1(dhcp-config)# network 192.168.11.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.11.1
R1(dhcp-config)# dns-server 192.168.50.195 209.165.202.158
R1(dhcp-config)# domain-name cisco.com
R1(dhcp-config)# lease 2
R1(dhcp-config)# netbios-name-server 192.168.11.254
R1(dhcp-config)# end

Le logiciel Cisco IOS supporte le service DHCPv4 par défaut. Pour le désactiver, utilisez la commande globale no service dhcp.

Pour vérifier les opérations DHCPv4 sur le routeur, utilisez les commandes de l’exemple B.

Exemple B – Vérification du fonctionnement du DHCPv4

R1# show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address 	Client-ID/ 		Lease expiration 	Type
    Hardware address/
    User name
192.168.10.10 	0100.1641.aea5.a7 	Jul 18 2008 08:17 AM 	Automatic
192.168.11.10 	0100.e018.5bdd.35 	Jul 18 2008 08:17 AM 	Automatic

R1# show ip dhcp server statistics
Memory usage 		26455
Address pools 		2
Database agents		0
Automatic bindings 	2
Manual bindings 	0
Expired bindings 	0
Malformed messages 	0
Secure arp entries 	0
Message Received
BOOTREQUEST 		0
DHCPDISCOVER 		2
DHCPREQUEST 		2
DHCPDECLINE 		0
DHCPRELEASE 		0
DHCPINFORM 		0

Message 		Sent
BOOTREPLY 		0
DHCPOFFER 		2
DHCPACK 		2
DHCPNAK 		0
R1#

Comme PC1 et PC2 sont connectés aux LAN, chacun reçoit automatiquement ses informations d’adresse IP du serveur DHCPv4 du routeur. L’exemple C montre la sortie de la commande ipconfig/all sur PC1.

Exemple C – Configuration du client DHCPv4

C:\> ipconfig/all

Windows IP Configuration

  Host Name . . . . . . . . . . . . : ciscolab
  Primary Dns Suffix . . . . . . . :
  Node Type . . . . . . . . . . . . : Hybrid
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

  Connection-specific DNS Suffix . : coursreseaux.com
  Description . . . . . . . . . . . : Intel(R) PRO/1000 PL
  Physical Address. . . . . . . . . : 00-7-48-AE-A5-A7
  Dhcp Enabled. . . . . . . . . . . : Yes
  Autoconfiguration Enabled . . . . : Yes
  IP Address. . . . . . . . . . . . : 192.168.10.11
  Subnet Mask . . . . . . . . . . . : 255.255.255.0
  Default Gateway . . . . . . . . . : 192.168.10.1
  DHCP Server . . . . . . . . . . . : 192.168.10.1
  DNS Servers . . . . . . . . . . . : 192.168.50.195
  Primary WINS Server . . . . . . . : 192.168.10.254
  Lease Obtained. . . . . . . . . . : Wednesday, July 16, 2018 8:16:59 AM
  Lease Expires . . . . . . . . . . : Friday, July 18, 2018 8:16:59 AM
C:\>

Pour désactiver la configuration DHCPv4 sur un client Windows, entrez la commande ipconfig/release. Pour renouveler la configuration DHCPv4, entrez la commande ipconfig/renew.

Configuration d’un routeur pour transmettre les requêtes DHCPv4

Dans un réseau complexe, les serveurs DHCPv4 sont généralement contenus dans une ferme de serveurs. Par conséquent, les clients ne sont généralement pas sur le même sous-réseau que le serveur DHCPv4, comme dans l’exemple précédent.

Pour vous assurer que les messages DHCPDISCOVER diffusés sont envoyés au serveur DHCPv4 distant, utilisez la commande ip helper-address.

Par exemple, dans la Figure C, le serveur DHCPv4 est situé sur le réseau local 192.168.11.0/24 et fournit des informations d’adressage IP pour les deux réseaux.

Figure C - Topologie de relais DHCPv4
Figure C – Topologie de relais DHCPv4

Sans la commande ip helper-address, R1 rejetterait toutes les émissions de PC1 demandant des services DHCPv4. Pour configurer R1 comme relais des messages DHCPDISCOVER, entrez les commandes suivantes :

R1(config)# interface gigabitethernet 0/0
R1(config-if)# ip helper-address 192.168.11.5

Notez que la commande est entrée sur l’interface qui recevra les diffusions DHCPv4. R1 achemine ensuite les messages de diffusion DHCPv4 en unicast vers 192.168.11.5. Par défaut, la commande ip helper-address transmet les huit services UDP suivants :

  • Port 37 : Heure
  • Port 49 : TACACS
  • Port 53 : DNS
  • Port 67 : Serveur DHCP/BOOTP
  • Port 68 : Client DHCP/BOOTP
  • Port 69 : TFTP
  • Port 137 : Service de nom NetBIOS
  • Port 138 : Service de datagrammes NetBIOS

Pour spécifier des ports supplémentaires, utilisez la commande globale ip forward-protocol udp[numéro de port | protocole]. Pour désactiver la diffusion d’un protocole particulier, utilisez la forme no de la commande.

Configuration d’un routeur en tant que client DHCPv4

Les routeurs Cisco des petits bureaux ou des succursales sont souvent configurés en tant que clients DHCPv4. La méthode utilisée dépend du FSI.

Cependant, dans sa configuration la plus simple, l’interface utilisée pour se connecter à un modem câble ou DSL est configurée avec la commande de configuration d’interface ip address dhcp.

Par exemple, dans la Figure D, l’interface GigabitEthernet 0/1 du routeur BRANCHE peut être configurée pour demander une adresse au routeur du FSI.

Figure D - Routeur en tant que client DHCP
Figure D – Routeur en tant que client DHCP

L’exemple D montre la configuration et la vérification de l’adressage DHCP sur BRANCHE.

Exemple D – Configuration d’un routeur en tant que client DHCP

BRANCHE(config)# interface g0/1
BRANCHE(config-if)# ip address dhcp
BRANCHE(config-if)# no shutdown
*Mar 15 08:45:34.632: %DHCP-6-ADDRESS_ASSIGN: Interface GigabitEthernet0/1
  assigned
    DHCP address 209.165.201.12, mask 255.255.255.224, hostname BRANCH
BRANCHE(config-if)# end
BRANCHE# show ip interface g0/1
GigabitEthernet0/1 is up, line protocol is up
  Internet address is 209.165.201.12/27
  Broadcast address is 255.255.255.255
  Address determined by DHCP

<sortie ignorée>

BRANCHE#

 

DHCPv6

IPv6 dispose de deux méthodes pour obtenir automatiquement une adresse unicast globale :

  • Auto-configuration d’adresse sans état (SLAAC)
  • Stateful DHCPv6 (protocole de configuration dynamique des hôtes pour IPv6)

SLAAC

SLAAC utilise les messages ICMPv6 de sollicitation de routeur (RS) et d’annonces de routeur (RA) pour fournir l’adressage et autres informations de configuration.

Un client utilise ensuite les informations du RA pour construire une adresse IPv6 et la vérifier avec un type spécial de sollicitation de voisinage (NS) appelé Duplicate Address Detection (DAD).

Ces trois types de messages (AR, RS et NS) appartiennent au protocole Network Discovery Protocol (protocole de recherche des voisins) :

Message de sollicitation de routeur (RS) : Lorsqu’un client est configuré pour obtenir son adresse automatiquement à l’aide de SLAAC, le client envoie un message RS au routeur. Le message RS est envoyé à l’adresse IPv6 multidiffusion “tous routeurs” FF02::2.

Message annonce du routeur (RA) : Un client utilise ces informations pour créer sa propre adresse IPv6 globale unicast. Un routeur envoie un message RA périodiquement ou en réponse à un message RS.

Le message RA comprend le préfixe et la longueur du préfixe du segment local. Par défaut, les routeurs Cisco envoient des messages RA toutes les 200 secondes. Les messages RA sont envoyés à l’adresse IPv6 multicast “tous noeuds” FF02::1.

Message de sollicitation de voisinage (NS) : Un message NS est normalement utilisé pour apprendre l’adresse de la couche de liaison de données d’un voisin sur le même réseau. Dans le processus SLAAC, un hôte utilise la détection d’adresse en double (DAD) en insérant sa propre adresse IPv6 comme adresse de destination dans un NS.

Le NS est envoyé sur le réseau pour vérifier qu’une adresse IPv6 nouvellement frappée est unique. Si une annonce voisine (Neighbor Advertisement) est reçue, l’hôte sait que l’adresse IPv6 n’est pas unique.

La figure E illustre le processus du SLAAC à l’aide de trois messages du protocole de découverte des voisins NDP (Neighbor Discovery Protocol).

Figure E - Découverte des voisins ( Neighbor Discovery ) et processus du SLAAC
Figure E – Découverte des voisins ( Neighbor Discovery ) et processus du SLAAC

Revoyons brièvement les étapes de la Figure E.

Étape 1. PC-B envoie un message RS à l’adresse IPv6 multicast “tous routeurs” FF02::2, pour informer le routeur IPv6 local qu’il a besoin d’un RA.

Étape 2. RouterA reçoit le message RS et répond par un message RA. Le message RA comprend le préfixe et la longueur du préfixe du réseau. Le message RA est envoyé à l’adresse IPv6 multicast “tous noeuds” FF02::1, avec l’adresse link-local du routeur comme adresse source IPv6.

Étape 3. PC-B utilise ces informations pour créer sa propre adresse IPv6 globale unicast. Il ajoute l’adresse du préfixe 64 bits à son propre ID d’interface 64 bits généré localement, qu’il a crée en utilisant soit le processus EUI (voir Figure E) soit un générateur de nombres aléatoires. Il utilise l’adresse link-local de RouterA comme passerelle par défaut.

Étape 4. Avant que PC-B puisse utiliser cette adresse IPv6 nouvellement créée, il utilise le processus DAD et envoie un NS pour vérifier que l’adresse est unique.

REMARQUE : Le système d’exploitation d’un client peut être configuré pour ignorer les messages RA, en choisissant toujours d’utiliser les services d’un serveur DHCPv6.

Un message RA informe un client de la façon d’obtenir un adressage automatique IPv6 : SLAAC, DHCPv6, ou une combinaison des deux.

Le message RA contient deux indicateurs pour indiquer l’option de configuration : l’indicateur Managed Address Configuration (indicateur M) et l’indicateur Other Configuration (indicateur O).

Le réglage par défaut de ces indicateurs est 0, ou les deux bits sont désactivés. Pour le client, cela signifie qu’il doit utiliser le processus SLAAC exclusivement pour obtenir toutes ses informations d’adressage IPv6. Si l’un de ces indicateurs est mis à 1 pour une raison quelconque, vous pouvez utiliser la forme no des commandes ipv6 nd suivantes dans l’interface pour les remettre à 0.

Router(config-if)# no ipv6 nd managed-config-flag
Router(config-if)# no ipv6 nd other-config-flag

 

DHCPv6 stateless

Dans DHCPv6 stateless (sans état), le client utilise le message RA du routeur pour générer son adresse unicast globale. Cependant, le client envoie ensuite une requête au serveur DHCPv6 pour obtenir toute information supplémentaire que le RA n’a pas déjà fournie.

Pour le DHCPv6 stateless, l’indicateur O est mis à 1 pour que le client soit informé que des informations de configuration supplémentaires sont disponibles depuis un serveur DHCPv6 stateless. Utilisez la commande suivante sur l’interface pour modifier le message RA :

Router(config-if)# ipv6 nd other-config-flag

DHCPv6 stateful (à état dynamique)

Pour le DHCPv6 stateful , le message RA indique au client d’obtenir toutes ses informations d’adressage d’un serveur DHCPv6. L’indicateur M doit être activé sur l’interface avec la commande suivante :

Router(config-if)# ipv6 nd managed-config-flag

Fonctionnement des DHCPv6 Stateless et Stateful

La Figure F montre le fonctionnement complet du DHCPv6, quelle que soit la méthode utilisée: SLAAC, DHCPv6 stateless, ou DHCPv6 stateful.

Figure F - Fonctionnement du DHCPv6
Figure F – Fonctionnement du DHCPv6

Les étapes suivantes résument la Figure F:

Étape 1. PC1 envoie un RS au démarrage pour commencer le processus d’obtention de l’adressage IPv6.

Étape 2. R1 répond avec un RA. Si les indicateurs M et O ne sont pas activés, PC1 utilise SLAAC. Si l’indicateur M ou O est activé, PC1 lance le processus DHCPv6.

Étape 3. PC1 envoie un message DHCPv6 SOLICIT à l’adresse de tous les serveurs DHCPv6 FF02::1:2 – une adresse de multidiffusion link-local qui ne sera pas transmise par les routeurs.

Étape 4. Un serveur DHCPv6 répond avec un message DHCPv6 ADVERTISE unicast informant le client de sa présence.

Étape 5. Le client envoie alors soit une demande DHCPv6 REQUEST unicast (l’option M a été activée et le client utilise le DHCPv6 dynamique) soit une demande DHCPv6 INFORMATION-REQUEST unicast (l’option O a été activée et le client utilise DHCPv6 sans état).

Étape 6. Le serveur répond avec les informations demandées.

Options de configuration DHCPv6

Un routeur peut être configuré en tant que serveur DHCPv6 sans état, serveur DHCPv6 dynamique et client DHCPv6. Comme dans DHCPv4, le routeur peut être configuré avec les trois, selon le rôle qu’il joue pour ses différentes interfaces.

Configuration d’un routeur en tant que serveur DHCPv6 sans état

Nous utilisons la figure G pour tous les exemples que nous présentons dans cette section. R1 est le serveur DHCPv6 et R3 est le client DHCPv6.

Figure G - Topologie de serveur et client DHCPv6
Figure G – Topologie de serveur et client DHCPv6

Pour configurer R1 comme serveur DHCP sans état, vous devez vous assurer que la commande ipv6 unicast-routing est activé. Ensuite, en mode de configuration globale, configurez le nom du pool, le serveur DNS et le nom de domaine.

Enfin, activez le pool DHCPv6 sur l’interface appropriée et activez l’option O pour que les clients sur cette interface sachent qu’ils doivent demander des services DHCPv6 au routeur. L’exemple E montre la configuration pour R1.

Exemple E – Configuration d’un routeur en tant que serveur DHCPv6 stateless

R1(config)# ipv6 unicast-routing
R1(config)# ipv6 dhcp pool O-FLAG-SET
R1(config-dhcpv6)# dns-server 2001:db8:acad:1::5
R1(config-dhcpv6)# domain-name cisco.com
R1(config-dhcpv6)# exit
R1(config)# interface g0/1
R1(config-if)# ipv6 address 2001:db8:1:1::1/64
R1(config-if)# ipv6 dhcp server O-FLAG-SET
R1(config-if)# ipv6 nd other-config-flag
R1(config-if)# end
R1# show ipv6 dhcp pool
DHCPv6 pool: O-FLAG-SET
  DNS server: 2001:DB8:ACAD:1::5
  Domain name: cisco.com
  Active clients: 0
R1#

Pour configurer une interface de routeur comme client DHCPv6, activez IPv6 sur l’interface et entrez la commande ipv6 address autoconfig, comme dans l’exemple F. Vérifiez la configuration avec la commande show ipv6 interface.

Exemple F – Configuration d’une interface en tant que client DHCPv6

R3(config)# interface g0/1
R3(config-if)# ipv6 enable
R3(config-if)# ipv6 address autoconfig
R3(config-if)# end
R3# show ipv6 interface g0/1
GigabitEthernet0/1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::32F7:DFF:FE25:2DE1
  No Virtual link-local address(es):
  Stateless address autoconfig enabled
  Global unicast address(es):
   2001:DB8:1:1:32F7:DFF:FE25:2DE1, subnet is 2001:DB8:1:1::/64 [EUI/CAL/PRE]
    valid lifetime 2591935 preferred lifetime 604735
  Joined group address(es):
    FF02::1
    FF02::1:FF25:2DE1
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND NS retransmit interval is 1000 milliseconds
  Default router is FE80::D68C:B5FF:FECE:A0C1 on GigabitEthernet0/1
R3#

 

Configuration d’un routeur en tant que serveur DHCPv6 Stateful

La principale différence entre une configuration stateless et une configuration stateful est qu’un serveur stateful inclut également des informations d’adressage IPv6 et conserve un enregistrement des adresses IPv6 qui sont louées.

Aussi, pour le côté client, la commande ipv6 address dhcp est utilisée à la place de la commande ipv6 address autoconfig. L’exemple G montre la configuration de serveur DHCPv6 stateful avec les informations d’adresse stateful ajoutées et le bit M activé au lieu du bit O.

Dépannage du protocole DHCP

Les problèmes DHCP peuvent survenir pour une multitude de raisons, telles que des défauts logiciels dans les systèmes d’exploitation, les pilotes NIC ou les agents relais DHCP. Cependant, les problèmes de configuration sont les plus courants.

Résoudre les conflits d’adresses IPv4

Un bail d’adresse IPv4 peut expirer sur un client toujours connecté à un réseau. Si le client ne renouvelle pas le bail, le serveur DHCP peut réattribuer cette adresse IPv4 à un autre client. Lorsque le client redémarre, il demande une adresse IPv4.

Si le serveur DHCP ne répond pas rapidement, le client utilise la dernière adresse IPv4. Ensuite, deux clients commencent à utiliser la même adresse IPv4, ce qui crée un conflit.

La commande show ip dhcp conflict affiche tous les conflits d’adresses enregistrés par le serveur DHCP. Le serveur utilise la commande ping pour détecter les conflits.

Le client DHCP utilise le protocole de résolution d’adresse (ARP) pour détecter les clients. Si un conflit d’adresse est détecté, l’adresse est retirée du pool et n’est pas attribuée tant qu’un administrateur n’a pas résolu le conflit.

Tester la connectivité à l’aide d’une adresse IP statique

Lors du dépannage d’un problème DHCP, vérifiez la connectivité réseau en configurant les informations d’adresse IPv4 statique sur un poste de travail client.

Si le poste de travail ne peut pas atteindre les ressources réseau avec une adresse IPv4 configurée statiquement, la cause profonde du problème n’est pas le serveur DHCP. A ce stade, un dépannage de la connectivité réseau est nécessaire.

Vérifier la configuration du port du commutateur

Si le client DHCP ne peut pas obtenir une adresse IPv4 du serveur DHCP au démarrage, essayez d’obtenir une adresse IPv4 du serveur DHCP en forçant manuellement le client à envoyer une requête DHCP.

Si un commutateur se trouve entre le client et le serveur DHCP et que le client ne peut pas obtenir la configuration DHCP, des problèmes de configuration du port de commutation peuvent en être la cause. Ces causes peuvent inclure des problèmes de trunking et de canalisation vers STP et RSTP.

La configuration PortFast et les configurations de ports de périphérie résolvent les problèmes clients DHCPv4 les plus courants qui surviennent lors de l’installation initiale d’un commutateur Cisco.

Tester le fonctionnement du DHCPv4 sur le même sous-réseau ou VLAN

Il est important de savoir si le DHCP fonctionne correctement lorsque le client est sur le même sous-réseau ou VLAN que le serveur DHCP.

Si le DHCP fonctionne correctement lorsque le client est sur le même sous-réseau ou VLAN, le problème peut être l’agent relais DHCP.

Si le problème persiste même avec le test DHCP sur le même sous-réseau ou VLAN que le serveur DHCP, le problème peut se poser avec le serveur DHCP.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image