Apprendre à configurer et dépanner Etherchannel

Apprendre à configurer et dépanner Etherchannel

La technologie EtherChannel vous permet de regrouper plusieurs interfaces physiques dans un canal logique pour augmenter la bande passante sur les liaisons point à point. De plus, EtherChannel fournit un moyen de prévenir le besoin de convergence STP (Spanning Tree Protocol) lorsqu’une seule défaillance de port ou de câble survient.

Fonctionnement d’EtherChannel

EtherChannel, une technologie développée par Cisco, peut regrouper jusqu’à huit liaisons à vitesse égale entre deux commutateurs, comme vous pouvez le voir entre les deux commutateurs de la couche de distribution à la Figure A.

Figure A - Exemple de topologie EtherChannel
Figure A – Exemple de topologie EtherChannel

STP considère le faisceau de liens comme une interface unique. Par conséquent, si au moins l’une des liaisons est up, la convergence STP n’a pas besoin de se produire.

Cela permet une meilleure utilisation de la bande passante disponible tout en réduisant le nombre de convergences STP. Sans utiliser EtherChannel ou modifier la configuration STP, STP bloquerait tous les liens redondants sauf un.

Avantages d’EtherChannel

Lorsqu’un EtherChannel est configuré, l’interface virtuelle résultante est appelée canal de port (port channel en anglais). Les interfaces physiques sont regroupées dans une interface de canal de port. EtherChannel présente les avantages suivants :

  • La plupart des tâches de configuration peuvent être effectuées sur l’interface EtherChannel plutôt que sur chaque port individuel, assurant ainsi la cohérence de la configuration à travers les liens.
  • EtherChannel s’appuie sur les ports de commutation existants pour augmenter la bande passante. Aucune mise à niveau matérielle n’est nécessaire.
  • L’équilibrage de charge est possible entre les liaisons qui font partie d’un même EtherChannel. (La configuration de l’équilibrage de charge dépasse le cadre de l’examen CCNA).
  • EtherChannel crée une agrégation que STP reconnaît comme un lien seul logique.
  • EtherChannel assure la redondance. La perte d’un lien physique ne crée pas de changement dans la topologie.

Restrictions de mise en œuvre d’EtherChannel

Gardez à l’esprit quelques limitations lorsque vous implémentez EtherChannel sur les commutateurs Catalyst Cisco 2960 :

  • Les types d’interface, tels que Fast Ethernet et Gigabit Ethernet, ne peuvent pas se mélanger dans le même EtherChannel.
  • Chaque EtherChannel peut comporter jusqu’à huit ports Ethernet configurés de manière compatible.
  • Le logiciel Cisco IOS supporte actuellement jusqu’à six canaux EtherChannels.
  • Certains serveurs prennent également en charge EtherChannel vers le commutateur pour augmenter la bande passante ; cependant, le serveur a besoin d’au moins deux canaux EtherChannel pour assurer la redondance car il peut envoyer du trafic vers un seul commutateur via EtherChannel.
  • La configuration de l’EtherChannel doit être cohérente sur les deux commutateurs. La configuration du trunking (VLAN natif, VLAN autorisés, etc.) doit être la même. Tous les ports doivent également être des ports de couche 2.
  • Tous les ports du canal EtherChannel doivent être des ports de couche 2, ou tous les ports du canal EtherChannel doivent être des ports de couche 3.

REMARQUE: Vous pouvez configurer les EtherChannels de couche 3 sur les commutateurs multicouches ; cependant, cela dépasse le cadre de l’examen CCNA.

Protocoles EtherChannel

Vous pouvez configurer EtherChannel comme statique ou inconditionnel ; cependant, vous pouvez également utiliser deux protocoles pour configurer le processus de négociation : Protocole d’agrégation de ports (propriétaire PAgP-Cisco) et protocole de contrôle d’agrégation de liens (LACP-IEEE 802.3ad).

Ces deux protocoles garantissent que les deux côtés de la liaison ont des configurations compatibles – même vitesse, même configuration duplex et mêmes informations VLAN. Les modes pour chacun diffèrent légèrement.

Protocole d’agrégation des ports PAgP

PAgP est un protocole propriétaire Cisco qui aide à la création automatique des liaisons EtherChannel. PAgP vérifie la cohérence de la configuration et gère les ajouts et les échecs de liens entre deux commutateurs.

Il garantit que lorsqu’un EtherChannel est créé, tous les ports ont le même type de configuration. PAgP utilise les modes suivants :

On : Ce mode force l’interface à se canaliser sans PAgP.

Desirable : L’interface lance des négociations avec d’autres interfaces en envoyant des paquets PAgP.

Auto : L’interface répond aux paquets PAgP qu’elle reçoit mais ne lance pas la négociation PAgP.

Les modes doivent être compatibles de chaque côté de l’EtherChannel. Par exemple, Sw1 et Sw2 de la Figure B doivent être configurés avec l’une des combinaisons de réglages du Tableau A.

Figure B - Topologie EtherChannel à deux commutateurs
Figure B – Topologie EtherChannel à deux commutateurs

Tableau A – Réglages de mode PAgP

SW1SW2Canal établi ?
On
OnOui
Auto/DesirableDesirableOui
On/Auto/DesirableNot configuredNon
OnDesirableNon
Auto/OnAutoNon

Protocole de contrôle de l’agrégation des liens LACP

Le protocole LACP (Link Aggregation Control Protocol) fait partie d’une spécification IEEE (802.3ad) qui permet à un commutateur de négocier un pack automatique en envoyant les paquets LACP à son correspondant.

Il remplit une fonction similaire à celle du PAgP avec Cisco EtherChannel. Les appareils Cisco prennent en charge à la fois le PAgP et le LACP. LACP utilise les modes suivants :

On : Ce mode force l’interface à se canaliser sans LACP.

Actif : L’interface lance des négociations avec d’autres interfaces en envoyant des paquets LACP.

Passif : L’interface répond aux paquets LACP qu’elle reçoit mais n’initie pas la négociation LACP.

Comme pour le PAgP, les modes LACP doivent être compatibles de chaque côté de l’EtherChannel. Par exemple, Sw1 et Sw2 de la Figure B doivent être configurés avec l’une des combinaisons de réglages du Tableau B.

Tableau B – Paramètres de mode LACP

SW1SW2Canal établi ?
On
OnOui
Active/PassiveActiveOui
On/Active/PassiveNot configuredNon
OnActiveNon
Passive/OnPassiveNon

NOTE: Pour les deux protocoles, le mode ON crée la configuration EtherChannel sans condition, sans négociation dynamique PAgP ou LACP. Vous devriez probablement mémoriser les réglages du mode PAgP et LACP en préparation de l’examen CCNA.

Configuration de canal EtherChannel

Pour implémenter EtherChannel, procédez comme suit :

Étape 1. Spécifiez les interfaces que vous voulez regrouper dans un seul lien à l’aide de la commande interface range.

Étape 2. Créez un canal de port à l’aide de la commande channel-group identifier mode mode. L’identificateur peut être n’importe quel nombre entre 1 et 6, inclusivement, et ne doit pas nécessairement concorder avec l’autre commutateur. Le mode est ON ou l’un des modes PAgP ou LACP.

Étape 3. Entrer le mode de configuration de l’interface pour le nouveau canal de port à l’aide de la commande interface port-channel identifier . L’identificateur est le même numéro que celui utilisé dans la commande channel-group.

Étape 4. Configurez les paramètres de trunking et de VLAN.

En utilisant la topologie de la figure B, supposons que Sw1 est déjà configuré pour EtherChannel avec G0/1 et G0/2. Le VLAN natif est de 86. Les VLAN autorisés sont 1, 10, 20 et 86. EtherChannel est forcé sur on. Aucun PAgP ou LACP n’est nécessaire. L’exemple A montre la configuration pour Sw2.

Exemple A – Configuration de canal EtherChannel

Sw2(config)# interface range g0/1-2
Sw2(config-if-range)# channel-group 1 mode on
Creating a port-channel interface Port-channel 1
Sw2(config-if-range)# interface port-channel 1
Sw2(config-if)# switchport mode trunk
Sw2(config-if)# switchport trunk native vlan 86
Sw2(config-if)# switchport trunk allowed vlan 1,10,20,86

Pour configurer PAgP ou LACP, utilisez le mot-clé approprié du mode pour la commande channel-group. Il suffit de s’assurer que les commandes des deux côtés du canal sont compatibles selon les tableaux A et B.

Vérification d’EtherChannel

Si vous avez configuré l’adressage de gestion, vous pouvez rapidement vérifier les deux côtés d’un canal EtherChannel en faisant un ping sur le trunk. Les deux commutateurs devraient être capables de pinguer l’un l’autre.

Les périphériques configurés en tant que membres des différents VLAN doivent également pouvoir s’envoyer des pings les uns aux autres. Pour vérifier la configuration, utilisez la commande show run (voir exemple B).

Exemple B – Vérification de la configuration de canal EtherChannel

Sw2# show run | begin interface Port
interface Port-channel1
  switchport trunk native vlan 86
  switchport trunk allowed vlan 1,10,20,86
  switchport mode trunk
!
<texte omis>
!
interface GigabitEthernet0/1
  switchport trunk native vlan 86
  switchport trunk allowed vlan 1,10,20,86
  switchport mode trunk
  channel-group 1 mode on
!
interface GigabitEthernet0/2
  switchport trunk native vlan 86
  switchport trunk allowed vlan 1,10,20,86
  switchport mode trunk
  channel-group 1 mode on

Pour obtenir un résumé général de la configuration d’EtherChannel, utilisez la commande show etherchannel summary (voir Exemple C).

Exemple C – Vérification du fonctionnement d’EtherChannel

Sw2# show etherchannel summary
Flags: D - down P - bundled in port-channel
  I - stand-alone s - suspended
  H - Hot-standby (LACP only)
  R - Layer3 S - Layer2
  U - in use f - failed to allocate aggregator

  M - not in use, minimum links not met
  u - unsuitable for bundling
  w - waiting to be aggregated
  d - default port


Number of channel-groups in use	: 1
Number of aggregators		: 1

Group 	Port-channel 	Protocol 	Ports
------+-------------+-----------+-----------------------------------------------
1 	Po1(SU) 	- 		Gig0/1(P) 	Gig0/2(P)

Pour vérifier l’état de fonctionnement d’une interface spécifique du canal EtherChannel, utilisez la commande show interface switchport (voir exemple D).

Exemple D – Vérification des paramètres d’une interface Port Channel

Sw2# show interface fa0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk (member of bundle Po1)
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 86 (VLAN0086)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 1,10,20,86
Pruning VLANs Enabled: 2-1001

Dépannage d’EtherChannel

Toutes les interfaces d’un EtherChannel doivent avoir la même configuration de vitesse et de mode duplex, des VLANs natifs et autorisés sur les trunks, et des VLANs d’accès sur les ports d’accès :

  • Attribuer tous les ports du EtherChannel au même VLAN ou les configurer en tant que trunks. Les ports avec différents VLAN natifs ne peuvent pas former un EtherChannel.
  • Lors de la configuration d’un trunk sur un EtherChannel, vérifier le mode de trunking sur l’EtherChannel. Il n’est pas recommandé de configurer le mode de trunking sur les ports individuels qui composent l’EtherChannel. Cependant, si c’est le cas, vérifiez que la configuration du trunking est la même sur toutes les interfaces.
  • Un EtherChannel prend en charge la même plage autorisée de VLAN sur tous les ports. Si la plage autorisée des VLANs n’est pas la même, les ports ne forment pas un EtherChannel même lorsque PAgP est réglé en mode auto ou desirable.
  • Les options de négociation dynamique pour PAgP et LACP doivent être configurées de manière compatible sur les deux extrémités de l’EtherChannel.

Les problèmes de configuration avec la commande channel-group incluent ce qui suit :

  • Configurer le mot-clé on sur un commutateur, et desirable, auto, active, ou passive sur l’autre commutateur. Le mot-clé on n’active pas PAgP ou LACP. Les deux commutateurs doivent être configurés sur l’un des modes PAgP ou LACP acceptables.
  • Configurer le mot-clé auto sur les deux commutateurs active PAgP, mais les deux commutateurs attendent sur l’autre commutateur pour commencer les négociations.
  • Configurer le mot-clé passif sur les deux commutateurs permet d’activer le LACP, mais les deux sont en attente sur l’autre commutateur pour commencer les négociations.
  • Mélanger des mots-clés de PAgP et LACP, qui ne sont pas compatibles. Par exemple, configurer active (LACP) sur un commutateur et desirable ou auto (PAgP) sur l’autre commutateur.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image