Apprendre à configurer et dépanner HSRP

Apprendre à configurer et dépanner HSRP

L’objectif de cet article est de vous aider à Apprendre à configurer et dépanner HSRP. Comme vous le savez, la plupart des terminaux ne stockent pas les routes pour atteindre les réseaux distants.

Au lieu de cela, ils sont configurés avec une passerelle par défaut qui gère le routage pour eux. Mais que faire si cette passerelle par défaut échoue ? Pour vous assurer qu’un périphérique aura toujours accès aux réseaux distants, vous devez implémenter un certain type de redondance de passerelle par défaut dans le réseau.

C’est le rôle des premiers protocoles de redondance de saut (First Hop Redundancy Protocols – FHRPs). Hot Standby Router Protocol (HSRP) est le seul FHRP que l’examen CCNA couvre.

Concepts de redondance du premier-saut (First-Hop Redundancy)

Les FHRPs (First-Hop Redundancy Protocol) vous permettent d’installer plusieurs routeurs dans un sous-réseau pour agir collectivement comme un seul routeur par défaut. Ces routeurs partagent une adresse IP virtuelle, comme le montre la Figure A.

Figure A - Exemple de passerelle par défaut redondante
Figure A – Exemple de passerelle par défaut redondante

Dans la figure, les interfaces G0/0 sur R1 et R2 sont configurées avec les adresses IP indiquées. Cependant, les deux routeurs sont également configurés avec l’IP virtuelle.

Cette adresse IP virtuelle est l’adresse de passerelle par défaut configurée sur les terminaux. Un protocole de redondance fournit le mécanisme permettant de déterminer quel routeur doit jouer un rôle actif dans la transmission du trafic.

Il détermine également quand un routeur de secours (standby) doit prendre en charge le rôle de transfert de données. La transition d’un routeur de transfert à un autre est transparente pour les terminaux.

Cette capacité du réseau à se rétablir dynamiquement de la défaillance d’un dispositif servant de passerelle par défaut est connue sous le nom de redondance du premier saut (First-Hop Redundancy).

Quelle que soit la mise en œuvre FHRP, les étapes suivantes ont lieu lorsque le routeur actif tombe en panne :

Étape 1. Le routeur de secours cesse de voir les messages hello du routeur de transfert.

Étape 2. Le routeur de secours assume le rôle de routeur de transfert.

Étape 3. Parce que le nouveau routeur de redirection prend en charge à la fois les adresses IP et MAC du routeur virtuel les stations terminales ne reconnaissent pas une interruption de service.

FHRPs ((First-Hop Redundancy Protocols)

La liste suivante définit les trois options disponibles pour les FHRPs:

Hot Standby Router Protocol (HSRP) : Un FHRP propriétaire Cisco conçu pour permettre le basculement transparent d’un périphérique IPv4 de premier saut.

La fonction du routeur de secours HSRP est de surveiller l’état opérationnel du groupe HSRP et d’assumer rapidement la responsabilité du transfert de paquets si le routeur actif tombe en panne. HSRP pour IPv6 prend en charge les réseaux IPv6.

Virtual Router Redundancy Protocol (VRRP) : Norme IETF qui attribue dynamiquement la responsabilité d’un ou plusieurs routeurs virtuels aux routeurs VRRP d’un LAN IPv4. Le fonctionnement est similaire à celui du HSRP. VRRPv3 supporte IPv4 et IPv6.

Gateway Load Balancing Protocol (GLBP):Un FHRP propriétaire Cisco qui protège le trafic de données d’un routeur ou d’un circuit défaillant, comme dans HSRP et VRRP, tout en permettant l’équilibrage de charge (également appelé load sharing) entre un groupe de routeurs redondants. GLBP pour IPv6 assure la prise en charge des réseaux IPv6.

L’examen CCNA couvre le HSRP seulement.

Fonctionnement du HSRP

HSRP utilise un modèle active/standby dans lequel un routeur assume activement le rôle de passerelle par défaut pour les périphériques du sous-réseau. Un ou plusieurs routeurs du même sous-réseau sont alors en mode veille (standby).

Le routeur actif HSRP implémente une adresse IP virtuelle et une adresse MAC virtuelle correspondante. Cette adresse IP virtuelle fait partie de la configuration HSRP et appartient au même sous-réseau que l’adresse IP de l’interface physique, mais c’est une adresse IP différente.

Le routeur crée alors automatiquement l’adresse MAC virtuelle. Tous les routeurs HSRP coopérants connaissent ces adresses virtuelles, mais seul le routeur actif HSRP utilise ces adresses à un moment donné.

Supposons que vous avez deux routeurs HSRP similaires à R1 et R2 dans la Figure A. Ces routeurs HSRP s’envoient mutuellement des messages pour négocier quel routeur doit être actif.

Ensuite, ils continuent à s’envoyer des messages afin que le routeur de secours puisse détecter quand le routeur actif tombe en panne. Si le routeur actif tombe en panne, le routeur de secours prend automatiquement en charge les adresses IP et MAC virtuelles, servant de passerelle par défaut pour le LAN.

Le nouveau routeur actif envoie alors un un message ARP gratuitous pour que les commutateurs du sous-réseau changent leurs tables d’adresses MAC afin de refléter le port correct pour atteindre l’adresse MAC virtuelle.

Ce processus de basculement est transparent pour les périphériques finaux, qui sont tous configurés avec l’adresse IP virtuelle comme passerelle par défaut.

Qu’en est-il de l’équilibrage de charge ? Ne sommes-nous pas en train de gaspiller la capacité du routeur de secours et des liens qui s’y connectent ? Oui, si les routeurs sont connectés à un seul sous-réseau.

Toutefois, si les VLAN sont configurés, en configurant chacun des routeur en mode HSRP actif pour certains des VLAN, les routeurs peuvent partager la charge de routage. Par exemple, dans la Figure A, R1 est le routeur actif pour VLAN 10, et R2 est le routeur actif pour VLAN 20.

Les deux routeurs sont configurés avec des sous-interfaces pour le routage inter-VLAN et deux adresses IP virtuelles afin que chacun puisse jouer le rôle de routeur actif si l’autre routeur tombe en panne. au même sous-réseau.

Versions de HSRP

Par défaut, Cisco IOS utilise la version HSRP 1. Le tableau A compare la version 1 et la version 2 du HSRP.

Tableau A – Fonctionnalités des versions 1 et 2 du protocole HSRP

Fonctionnalité HSRPVersion 1Version 2
Numéros de groupe pris en charge0–2550–4095
AuthentificationNoneMD5
Adresses multidiffusionIPv4: 224.0.0.2IPv4: 224.0.0.102

IPv6: FF02::66
Plages de MAC virtuelles0000.0C07.AC00 to 0000.0C07.ACFFIPv4: 0000.0C9F.F000 to 0000.0C9F.FFFF

IPv6: 0005.73A0.0000 to 0005.73A0.0FFF

REMARQUE: Les trois derniers chiffres hexadécimaux de l’adresse MAC virtuelle indiquent le numéro de groupe configuré. Les numéros de groupe sont importants pour les configurations HSRP plus avancées, qui dépassent la portée du CCNA.

Priorité et préemption du HSRP

Par défaut, le routeur avec l’adresse IPv4 numérique la plus élevée est choisi comme routeur HSRP actif. Pour configurer un routeur comme routeur actif quel que soit l’adressage IPv4, utilisez la commande de configuration de l’interface standby priority.

La priorité par défaut est 100. Le routeur ayant la priorité la plus élevée sera le routeur HSRP actif, en supposant qu’aucune option n’a déjà été choisie.

Pour forcer un nouveau choix HSRP, la préemption doit être activée avec la commande de configuration de l’interface standby preempt.

Configuration et vérification du HSRP

Voyons comment configurer la topologie dans la Figure A. HSRP ne nécessite qu’une seule commande sur les deux routeurs :

Router(config-if)# standby group ip ip-address

L’interface doit se trouver sur le même sous-réseau que le ou les autres routeurs HSRP. Le numéro de groupe et l’adresse IP virtuelle doivent être les mêmes sur tous les routeurs HSRP formant le même groupe HSRP.

A moins que la commande priority ne soit utilisée, le premier routeur configuré devient le routeur actif HSRP. Par conséquent, même si dans l’exemple A, R1 est configuré en premier, il inclut une configuration prioritaire pour s’assurer que R1 est toujours le routeur actif.

De plus, pour s’assurer que R1 reprend le rôle actif du routeur après avoir perdu la connectivité, la commande de standby preempt est configurée.

Exemple A – Configuration de HSRP

R1(config)# interface g0/0
R1(config-if)# ip address 10.1.1.1 255.255.0.0
R1(config-if)# standby 1 ip 10.1.1.254
R1(config-if)# standby 1 priority 200
R1(config-if)# standby 1 preempt

R2(config)# interface g0/0
R2(config-if)# ip address 10.1.1.2 255.255.0.0
R2(config-if)# standby 1 ip 10.1.1.254

Pour vérifier que HSRP est opérationnel, utilisez la commande show standby ou la version courte de la commande, comme dans l’exemple B.

Exemple B – Vérification de HSRP

R1# show standby
GigabitEthernet0/0 - Group 1
  State is Active
    2 state changes, last state change 00:11:51
  Virtual IP address is 10.1.1.254
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.232 secs
  Preemption enabled
  Active router is local
  Standby router is 10.1.1.2, priority 100 (expires in 9.808 sec)
  Priority 200 (configured 200)
  Group name is "hsrp-Gi0/0-1" (default)

R1# show standby brief
    P indicates configured to preempt.
    |
Interface 	Grp 	Pri P 	State 	Active 	Standby 	Virtual IP
Gi0/0 		1 	200 	Active 	local 	10.1.1.2 	10.1.1.254

R2# show standby
GigabitEthernet0/0 - Group 1
  State is Standby
    1 state change, last state change 00:15:23
  Virtual IP address is 10.1.1.254
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.008 secs
  Preemption disabled
  Active router is 10.1.1.1, priority 200 (expires in 8.624 sec)
  Standby router is local
  Priority 100 (default 100)
  Group name is "hsrp-Gi0/0-1" (default)

R2# show standby brief
    P indicates configured to preempt.
    |
Interface 	Grp 	Pri P 	State 	Active 		Standby 	Virtual IP
Gi0/0 		1 	100 	Standby 10.1.1.1 	local 		10.1.1.254

La commande show standby affiche les informations les plus pertinentes dont vous pourriez avoir besoin en quelques lignes de sortie.

La commande show standby la plus verbeuse fournit des informations supplémentaires, telles que le nombre de changements d’état, l’adresse MAC virtuelle, les messages hello, et le nom du groupe.

Équilibrage de charge HSRP

Comme avec STP, vous pouvez souhaiter que vos routeurs HSRP soient configurés à l’état actif/actif, avec un routeur actif pour un ensemble de VLANs et l’autre routeur actif pour les autres VLANs. La figure B montre une topologie avec plusieurs VLAN.

Figure B - Exemple d'équilibrage de charge HSRP
Figure B – Exemple d’équilibrage de charge HSRP

Pour mettre en œuvre l’équilibrage de charge HSRP pour différents VLAN, configurez R1 comme routeur actif pour la moitié des VLAN et R2 comme routeur actif pour l’autre moitié des VLAN (voir Exemple C).

Exemple C – Configuration de l’équilibrage de charge HSRP

R1# show run | begin interface G

interface GigabitEthernet0/0
  no ip address
  duplex auto
  speed auto
!
interface GigabitEthernet0/0.10
  encapsulation dot1Q 10
  ip address 10.1.10.1 255.255.255.0
  standby version 2
  standby 1 ip 10.1.10.254
  standby 1 priority 150
  standby 1 preempt
!
interface GigabitEthernet0/0.20
  encapsulation dot1Q 20
  ip address 10.1.20.1 255.255.255.0
  standby version 2
  standby 1 ip 10.1.20.254

R2# show run | begin interface G
interface GigabitEthernet0/0
  no ip address
  duplex auto
  speed auto
!
interface GigabitEthernet0/0.10
  encapsulation dot1Q 10
  ip address 10.1.10.2 255.255.255.0
  standby version 2
  standby 1 ip 10.1.10.254
!
interface GigabitEthernet0/0.20
  encapsulation dot1Q 20
  ip address 10.1.20.2 255.255.255.0
  standby version 2
  standby 1 ip 10.1.20.254
  standby 1 priority 150
  standby 1 preempt
!

 

Pour vérifier que HSRP est opérationnel avec équilibrage de charge, utilisez la commande show standby ou la version courte de la commande (voir Exemple C).

Exemple D – Vérification de l’équilibrage de charge avec HSRP

R1# show standby brief
        P indicates configured to preempt.
        |
Interface 	Grp 	Pri 	P State 	Active 		Standby 	Virtual IP
    1 	150 	Active 		local 		10.1.10.2 	10.1.10.254
    1 	100 	Standby 	10.1.20.2 	local 		10.1.20.254

R2# show standby brief
        P indicates configured to preempt.
        |
Interface 	Grp 	Pri 	P State 	Active 		Standby 	Virtual IP
    1 	100 	Standby 	10.1.10.1 	local 		10.1.20.254
    1 	150 	Active 		local 		10.1.20.1 	10.1.20.254

 

Dépannage de HSRP

Les problèmes liés au HSRP résultent très probablement d’un ou de plusieurs des facteurs suivants :

  • Le routeur actif qui contrôle l’adresse IP virtuelle du groupe n’a pas été élu avec succès.
  • Le routeur de secours n’a pas réussi à garder trace du routeur actif.
  • Aucune décision n’a été prise quant au moment de la remise du contrôle de l’IP virtuelle du groupe à un autre routeur.
  • Les périphériques finals n’ont pas réussi à configurer l’adresse IP virtuelle comme passerelle par défaut.

Les problèmes de configuration courants du HSRP sont les suivants :

  • Les routeurs HSRP ne sont pas connectés au même segment du réseau.
  • Les routeurs HSRP ne sont pas configurés avec des adresses IPv4 du même sous-réseau.
  • Les routeurs HSRP ne sont pas configurés avec la même adresse IPv4 virtuelle.
  • Les routeurs HSRP ne sont pas configurés avec le même numéro de groupe HSRP.
  • Les terminaux ne sont pas configurés avec l’adresse de passerelle par défaut correcte.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image