Configurer et dépanner OSPFv2 et OSPFv3

Configurer et dépanner OSPFv2 et OSPFv3

Aujourd’hui, nous passons en revue l’implémentation de base d’OSPFv2 et OSPFv3 pour la conception de réseaux à zone unique. Nous examinons les commandes pour configurer et vérifier l’implémentation. Dans un autre article, nous présentons l’implémentation de base d’OSPF multizone.

Configuration d’OSPFv2 mono-zone

Pour passer en revue les commandes de configuration de OSPFv2, nous utilisons la topologie de la Figure A et le schéma d’adressage du Tableau A.

Tableau A – Schéma d’adressage pour OSPFv2

Appareil

InterfaceAdresse IPMasque de sous-réseau
R1G0/0172.16.1.1255.255.255.0
S0/0/0172.16.3.1255.255.255.252
S0/0/1192.168.10.5255.255.255.252
R2

G0/0172.16.2.1255.255.255.0
S0/0/0172.16.3.2255.255.255.252
S0/0/1192.168.10.9255.255.255.252
R3
G0/0192.168.1.1255.255.255.0
S0/0/0192.168.10.6
255.255.255.252
S0/0/1192.168.10.10255.255.255.252

Figure A - Topologie de configuration OSPFv2
Figure A – Topologie de configuration OSPFv2

La commande router ospf

OSPF est activé avec la commande de configuration globale router ospf process-id :

R1(config)# router ospf process-id

Le parameter process-id est un nombre compris entre 1 et 65.535 et est choisi par l’administrateur réseau. L’ID de processus est significatif localement. Il n’a pas besoin de correspondre à d’autres routeurs OSPF pour établir des adjacences avec ces voisins.

Cela diffère du protocole EIGRP (Enhanced Interior Gateway Routing Protocol). L’ID de processus EIGRP et le numéro de système autonome doivent correspondre avant que deux voisins EIGRP ne deviennent adjacents.

Pour notre étude, nous activons OSPF sur les trois routeurs en utilisant le même ID de processus de 10.

ID de routeur

L’ID du routeur joue un rôle important dans l’OSPF en identifiant de manière unique chaque routeur dans le domaine de routage OSPF. Les routeurs Cisco dérivent l’ID du routeur en fonction de trois critères dans l’ordre suivant :

1. Le routeur utilise l’adresse IP configurée avec la commande OSPF router-id.

2. Si l’ID du routeur n’est pas configuré, le routeur choisit l’adresse IP la plus élevée parmi toutes ses interfaces de bouclage.

3. Si aucune interface de bouclage n’est configurée, le routeur choisit l’adresse IP active la plus élevée parmi toutes ses interfaces physiques.

L’ID du routeur peut être visualisé avec plusieurs commandes, y compris show ip ospf interfaces, show ip protocols, et show ip ospf.

Comme l’administrateur réseau peut contrôler la commande OSPF router-id et que les interfaces de bouclage encombrent la table de routage, il est préférable de configurer la commande router-id.

La commande router-id accepte une adresse IPv4 comme seul argument. L’exemple A montre les configurations d’ID de routeur pour les routeurs dans notre topologie.

Exemple A – Configurations de l’ID du routeur

R1(config-router)# router-id 1.1.1.1

R2(config-router)# router-id 2.2.2.2

R3(config-router)# router-id 3.3.3.3

L’ID du routeur est sélectionné lorsque OSPF est configuré avec sa première commande network, donc la commande router-id doit déjà être configurée.

Cependant, vous pouvez forcer OSPF à libérer son ID actuel et à utiliser l’ID de routeur configuré en effaçant le processus de routage OSPF :

Router# clear ip ospf process

La commande network

La commande network est utilisée en mode configuration du routeur :

Router(config-router)# network network-address wildcard-mask area area-id

La commande OSPF network utilise une combinaison d’adresse réseau et de masque générique. L’adresse réseau, ainsi que le masque générique, spécifient l’interface ou la plage d’interfaces qui sera activée pour OSPF à l’aide de cette commande network.

Le masque générique est habituellement configuré comme l’inverse d’un masque de sous-réseau. Par exemple, l’interface série 0/0/0 de R1 se trouve sur le réseau 172.16.3.0/30.

Le masque de sous-réseau pour cette interface est /30 ou 255.255.255.252. L’inverse du masque de sous-réseau donne le masque générique 0.0.0.0.3.

Le parameter area-id fait référence à une zone OSPF. Une zone OSPF est un groupe de routeurs qui partagent des informations d’état de liaison.

Tous les routeurs OSPF dans la même zone doivent avoir les mêmes informations d’état de liaison dans leurs bases de données d’état de liaison concerant la zone courante.

Par conséquent, tous les routeurs d’une même zone OSPF doivent être configurés avec le même identifiant de zone (area-id). Par convention, l’ID de zone est 0.

Comme alternative, OSPFv2 peut être activé en utilisant la commande de mode de configuration routeur intf-ip-address 0.0.0.0 area area-id.

L’exemple B montre les commandes network utilisées sur les trois routeurs pour activer OSPF sur toutes les interfaces. Pour R1, l’adresse IP de l’interface alternative et le masque générique quadri-zéro sont configurés.

Exemple B – Configuration de réseaux OSPF

R1(config)# router ospf 10
R1(config-router)# network 172.16.1.1 0.0.0.0 area 0
R1(config-router)# network 172.16.3.1 0.0.0.0 area 0
R1(config-router)# network 192.168.10.5 0.0.0.0 area 0

R2(config)# router ospf 10
R2(config-router)# network 172.16.2.0 0.0.0.255 area 0
R2(config-router)# network 172.16.3.0 0.0.0.3 area 0
R2(config-router)# network 192.168.10.8 0.0.0.3 area 0

R3(config)# router ospf 10
R3(config-router)# network 192.168.1.0 0.0.0.255 area 0
R3(config-router)# network 192.168.10.4 0.0.0.3 area 0
R3(config-router)# network 192.168.10.8 0.0.0.3 area 0

Interfaces passives

Par défaut, les messages OSPF sont transférés vers toutes les interfaces activées par OSPF. Cependant, ces messages n’ont vraiment besoin d’être envoyés que par des interfaces qui se connectent à d’autres routeurs activés par l’OSPF.

L’envoi de messages inutiles sur un réseau local affecte le réseau de trois façons :

Utilisation inefficace de la bande passante : La bande passante disponible est consommée pour transporter des messages inutiles.

Utilisation inefficace des ressources : Tous les périphériques du réseau local doivent traiter le message.

Risque accru pour la sécurité : Les messages OSPF peuvent être interceptés et les mises à jour de routage peuvent être modifiées, corrompant la table de routage.

Utilisez la commande passive-interface pour éviter que les mises à jour OSPF ne soient envoyées par des interfaces inutiles. Pour notre topologie de la Figure A, l’interface GigabitEthernet 0/0 de chaque routeur doit être réglée comme passive avec la commande suivante :

Router(config)# passive-interface gigabitethernet 0/0

Comme alternative, toutes les interfaces peuvent être rendues passives en utilisant la commande passive-interface default. Les interfaces qui ne doivent pas être passives peuvent alors être réactivées à l’aide de la commande no passive-interface.

Modification de la métrique OSPF

Le logiciel Cisco IOS utilise les bandes passantes cumulées des interfaces sortantes du routeur vers le réseau de destination comme valeur de coût. Pour chaque routeur, le coût d’une interface est calculé à l’aide de la formule suivante :

Coût Cisco IOS pour OSPF = 108/bande passante en bps

Dans ce calcul, la valeur 108 est appelée bande passante de référence. Le Tableau B montre les coûts OSPF par défaut en utilisant la bande passante de référence par défaut pour plusieurs types d’interfaces.

Tableau B – Valeurs par défaut Cisco des coûts OSPF

Type d'interfaceCoût
10 Gigabit Ethernet (10 Gbps)1
Gigabit Ethernet (1 Gbps)1
Fast Ethernet (100 Mbps)1
Ethernet (10 Mbps)10
T1 (1.544 Mbps)
64
128 kbps781
64 kbps1562

Dans le tableau B, 10GigE, Gigabit Ethernet et Fast Ethernet ont tous le même coût. C’est parce que la valeur du coût OSPF doit être un entier. Ce n’était pas un problème avant l’introduction du gigabit et des débits de données plus élevés.

Cependant, les réseaux d’aujourd’hui fonctionnent certainement à des vitesses gigabit. Par conséquent, par principe, vous devriez changer la bande passante de référence pour prendre en charge les réseaux dont les liaisons sont supérieures à 100 000 000 de bps (100 Mbps).

Utilisez la commande suivante pour modifier la bande passante de référence :

Router(config-router)# auto-cost reference-bandwidth Mbps

Comme la valeur entrée est en mégabits par seconde, le changement de la bande passante de référence à 10000 garantit que tous les routeurs OSPF sont prêts à calculer avec précision le coût des réseaux 10GigE.

Lorsqu’elle est utilisée, cette commande doit être entrée sur tous les routeurs afin que la métrique de routage OSPF reste cohérente. En fait, l’IOS Cisco répond avec le message syslog suivant lorsque vous configurez la commande auto-cost reference-bandwidth:

% OSPF: Reference bandwidth is changed.
        Please ensure reference bandwidth is consistent across all routers.

Pour notre topologie à la Figure A, nous entrons les commandes illustrées dans l’exemple C.

Exemple C – Modification de la bande passante de référence OSPF

R1(config-router)# auto-cost reference-bandwidth 10000

R2(config-router)# auto-cost reference-bandwidth 10000

R3(config-router)# auto-cost reference-bandwidth 10000

Le tableau C montre les valeurs du coût modifiées avec la nouvelle bande passante de référence de 10 000 000 000 bps, ou 1010.

Tableau C – Valeurs de coût OSPF avec bande passante de référence modifiée = 10000

Type d'interfaceCoût
10 Gigabit Ethernet (10 Gbps)1
Gigabit Ethernet (1 Gbps)10
Fast Ethernet (100 Mbps)100
Ethernet (10 Mbps)1000
T1 (1.544 Mbps)6477
128 kbps78125
64 kbps156250

REMARQUE : Bien que le coût pour une vitesse de 64 kbps est 156250, le coût maximum OSPF pour une interface de routeur Cisco est 65535.

Mais nous n’avons pas fini : Il nous reste encore un ajustement à faire pour nous assurer que OSPF utilise des coûts exacts.

Sur les routeurs Cisco, la bande passante par défaut sur la plupart des interfaces série est réglée à la vitesse T1, soit 1,544 Mbps. Mais dans notre topologie de la Figure A, nous avons les vitesses réelles suivantes :

  • La liaison entre R1 et R2 fonctionne à 1544 kbps (valeur par défaut).
  • La liaison entre R2 et R3 fonctionne à 1024 kbps.
  • La liaison entre R1 et R3 fonctionne à 64 kbps.

Vous pouvez modifier la métrique OSPF de deux façons :

  • Utilisez la commande bandwidth pour modifier la valeur de bande passante utilisée par Cisco IOS dans le calcul de la mesure du coût OSPF.
  • Utilisez la commande ip ospf cost, qui vous permet de spécifier directement le coût d’une interface.

Un avantage de la configuration d’un coût par rapport au réglage de la bande passante de l’interface est que le routeur n’a pas besoin de calculer la métrique lorsque le coût est configuré manuellement.

De plus, la commande ip ospf cost est utile dans les environnements multifournisseurs, où les routeurs non Cisco peuvent utiliser une métrique autre que la bande passante pour calculer les coûts OSPF.

Le Tableau D montre les deux alternatives qui peuvent être utilisées pour modifier les coûts des liaisons série dans la topologie de la Figure A. Le côté droit de la figure montre les équivalents de la commande ip ospf cost et de la commande bandwidth sur la gauche.

Tableau D – Comparaison des commandes bandwidth et ip ospf cost

Réglage de la bande passante de l'interface=Réglage manuel du coût OSPF
R1(config)# interface S0/0/1
=R1(config)# interface S0/0/1
R1(config-if)# bandwidth 64R1(config-if)# ip ospf cost 65535

R2(config)# interface S0/0/1=R2(config)# interface S0/0/1
R2(config-if)# bandwidth 1024R2(config-if)# ip ospf cost 9765
R3(config)# interface S0/0/0=R3(config)# interface S0/0/0
R3(config-if)# bandwidth 64R3(config-if)# ip ospf cost 65535
R3(config)# interface S0/0/1=R3(config)# interface S0/0/1
R3(config-if)# bandwidth 1024R3(config-if)# ip ospf cost 9765

REMARQUE : L’interface à 64 kbps est réglée au coût maximum de 65535.

Vérification d’OSPFv2

Pour vérifier toute configuration de routage, vous dépendrez très probablement des commandes show ip interface brief, show ip route et show ip protocols. Toutes les interfaces prévues doivent être en état up/up et doivent être configurées avec la bonne adresse IP.

La table de routage doit contenir tous les routes prévues. L’état du protocole doit indiquer le routage pour tous les réseaux attendus, ainsi que toutes les sources de routage attendues. L’exemple D montre la sortie de R1 pour ces trois commandes de base.

Exemple D – Commandes de vérification de routage de base de R1

R1# show ip route
<texte omis>

Gateway of last resort is not set

  172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C 		172.16.1.0/24 is directly connected, GigabitEthernet0/0
L 		172.16.1.1/32 is directly connected, GigabitEthernet0/0
O 		172.16.2.0/24 [110/6576] via 172.16.3.2, 00:04:57, Serial0/0/0
C 		172.16.3.0/30 is directly connected, Serial0/0/0
L 		172.16.3.1/32 is directly connected, Serial0/0/0
O 	192.168.1.0/24 [110/16341] via 172.16.3.2, 00:00:41, Serial0/0/0
  192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
C 		192.168.10.4/30 is directly connected, Serial0/0/1
L 		192.168.10.5/32 is directly connected, Serial0/0/1
O 		192.168.10.8/30 [110/16241] via 172.16.3.2, 00:00:41, Serial0/0/0

R1# show ip interface brief
Interface 			IP-Address 	OK? Method 	Status 			Protocol
Embedded-Service-Engine0/0 	unassigned 	YES unset 	administratively down 	down
GigabitEthernet0/0 		172.16.1.1 	YES manual 	up 			up
GigabitEthernet0/1 		unassigned 	YES unset 	administratively down 	down
Serial0/0/0 			172.16.3.1 	YES manual 	up 			up
Serial0/0/1 			192.168.10.5 	YES manual 	up 			up

R1# show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.0 0.0.0.255 area 0
    172.16.3.0 0.0.0.3 area 0
    192.168.10.4 0.0.0.3 area 0
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway 	Distance 	Last Update
    3.3.3.3 	110 		00:09:00
    2.2.2.2 	110 		00:09:00
  Distance: (default is 110)

Vous pouvez vérifier que les adjacences des voisins souhaités sont établies avec la commande show ip ospf neighbor. L’exemple E montre les tables des relations d’adjacence des trois routeurs.

Exemple E – Vérification de la relation de voisinage

R1# show ip ospf neighbor
Neighbor ID 	Pri 	State 		Dead Time 	Address 	Interface
3.3.3.3 	0 	FULL/ - 	00:00:37 	192.168.10.6 	Serial0/0/1
2.2.2.2 	0 	FULL/ -		00:00:37 	172.16.3.2 	Serial0/0/0

R2# show ip ospf neighbor
Neighbor ID 	Pri 	State 		Dead Time 	Address 	Interface
3.3.3.3 	0 	FULL/ - 	00:00:38 	192.168.10.10 	Serial0/0/1
1.1.1.1 	0 	FULL/ - 	00:00:37 	172.16.3.1 	Serial0/0/0

R3# show ip ospf neighbor
Neighbor ID 	Pri 	State 		Dead Time 	Address 	Interface
2.2.2.2 	0 	FULL/ - 	00:00:37 	192.168.10.9 	Serial0/0/1
1.1.1.1 	0 	FULL/ - 	00:00:30 	192.168.10.5 	Serial0/0/0

Pour chaque voisin, cette commande affiche la sortie suivante :

ID du voisin (Neighbor ID): L’ID du routeur du routeur voisin.

Priorité (Pri): La priorité OSPF de l’interface. Ils affichent tous 0 parce que les liaisons point à point ne choisissent pas un DR ou un BDR.

État (State): L’état OSPF de l’interface. FULL signifie que l’interface du routeur est entièrement adjacente à celle de son voisin et que les bases de données OSPF sont identiques.

Temps mort (Dead Time): Le temps d’attente restant que le routeur attendra pour recevoir un paquet hello OSPF du voisin avant de déclarer le voisin en panne. Cette valeur est réinitialisée lorsque l’interface reçoit un paquet hello.

Adresse: L’adresse IP de l’interface du voisin à laquelle ce routeur est directement connecté.

Interface: L’interface sur laquelle ce routeur a formé une adjacence avec le voisin.

La commande show ip ospf de l’exemple F pour R1 peut également être utilisée pour examiner l’ID de processus OSPF et l’ID de routeur. De plus, cette commande affiche les informations de la zone OSPF et la dernière fois que l’algorithme SPF a été calculé.

Exemple F – La commande show ip ospf

R1# show ip ospf
Routing Process "ospf 10" with ID 1.1.1.1
   Start time: 00:29:52.316, Time elapsed: 00:45:15.760
   Supports only single TOS(TOS0) routes
   Supports opaque LSA
   Supports Link-local Signaling (LLS)
   Supports area transit capability
   Supports NSSA (compatible with RFC 3101)
   Event-log enabled, Maximum number of events: 1000, Mode: cyclic
   Router is not originating router-LSAs with maximum metric
   Initial SPF schedule delay 5000 msecs
   Minimum hold time between two consecutive SPFs 10000 msecs
   Maximum wait time between two consecutive SPFs 10000 msecs
   Incremental-SPF disabled
   Minimum LSA interval 5 secs
   Minimum LSA arrival 1000 msecs
   LSA group pacing timer 240 secs
   Interface flood pacing timer 33 msecs
   Retransmission pacing timer 66 msecs
   Number of external LSA 0. Checksum Sum 0x000000
   Number of opaque AS LSA 0. Checksum Sum 0x000000
   Number of DCbitless external and opaque AS LSA 0
   Number of DoNotAge external and opaque AS LSA 0
   Number of areas in this router is 1. 1 normal 0 stub 0 nssa
   Number of areas transit capable is 0
   External flood list length 0
   IETF NSF helper support enabled
   Cisco NSF helper support enabled
   Reference bandwidth unit is 10000 mbps
      Area BACKBONE(0)
         Number of interfaces in this area is 3
         Area has no authentication
         SPF algorithm last executed 00:18:32.788 ago
         SPF algorithm executed 7 times
         Area ranges are
         Number of LSA 3. Checksum Sum 0x01BB59
         Number of opaque link LSA 0. Checksum Sum 0x000000
         Number of DCbitless LSA 0
         Number of indication LSA 0
         Number of DoNotAge LSA 0
         Flood list length 0

La façon la plus rapide de vérifier les paramètres de l’interface OSPF est d’utiliser la commande show ip ospf interface brief.

Comme indiqué dans la sortie pour R1 dans l’exemple G, cette commande fournit une liste détaillée pour chaque interface compatible OSPF.

La commande est également utile pour visualiser rapidement le coût de chaque interface et déterminer si les instructions network ont été correctement configurées.

Exemple G – La commande show ip ospf interface brief

R1# show ip ospf interface brief
Interface 	PID 	Area 	IP Address/Mask 	Cost 	State 	Nbrs F/C
Se0/0/1 	10 	0 	192.168.10.5/30 	65535 	P2P 	1/1
Se0/0/0 	10 	0 	172.16.3.1/30 		6476 	P2P 	1/1
Gi0/0 		10 	0 	172.16.1.1/24 		100 	DR 	0/0

Configuration OSPFv3 mono-zone

La configuration d’OSPFv3 nécessite les mêmes étapes de base que pour OSPFv2 : choisir et configurer un ID de processus, activer le processus sur chaque interface et affecter la zone OSPF correcte à chaque interface. Cependant, la façon dont ces étapes sont mises en œuvre est très différente.

La Figure B montre la topologie que nous utilisons pour examiner les étapes de configuration d’OSPFv3.

Figure B - Topologie de configuration OSPFv3
Figure B – Topologie de configuration OSPFv3

Pour faciliter nos étapes de configuration et de vérification, nous utilisons le schéma d’adressage IPv6 simplifié du Tableau E.

Tableau E – Schéma d’adressage pour OSPFv3

Appareil
Interface
Adresse / Préfixe IPv6
R1


G0/02001:DB8:1:1::1/64
S0/0/02001:DB8:1:A::1/64
S0/0/12001:DB8:1:C::1/64
Link-localFE80::1
R2G0/02001:DB8:1:2::1/64
S0/0/02001:DB8:1:A::2/64
S0/0/12001:DB8:1:B::1/64
Link-localFE80::2
R3


G0/02001:DB8:1:3::1/64
S0/0/02001:DB8:1:C::2/64
S0/0/12001:DB8:1:B::2/64
Link-localFE80::3

L’ID de routeur dans OSPFv3

Comme pour OSPFv2, OSPFv3 choisit l’ID du routeur dans l’ordre suivant :

1. Si la commande router-id est configurée, utilisez l’ID de routeur IPv4 configuré manuellement.

2. Si l’ID du routeur n’est pas configuré, utilisez l’adresse IPv4 de l’interface de bouclage configurée la plus élevée.

3. Si aucune adresse IPv4 en boucle n’est configurée, utiliser l’adresse IPv4 de l’interface configurée la plus élevée. L’interface peut être dans l’état up/up ou dans l’état up/down.

Comme pour OSPFv2, vous configurez l’ID de routeur avec la commande routeur-id en mode de configuration routeur.

Cependant, notez que OSPFv2 et OSPFv3 utilisent une adresse IPv4 pour l’ID de routeur. Cela signifie qu’avant qu’un routeur puisse démarrer un processus de routage OSPFv3, il doit y avoir une adresse IPv4 configurée – soit une interface, soit un identifiant de routeur.

Sinon, le routeur renvoie le message syslog suivant lorsque vous essayez d’activer le processus de routage OSPFv3 avec la commande ipv6 router ospf :

R1(config)# ipv6 router ospf 10
*Jun 3 13:06:06.579: %OSPFv3-4-NORTRID: Process OSPFv3-10-IPv6 could not pick a
s router-id, please configure manually

L’étape suivante sur R1 consiste donc à configurer l’ID de routeur. Il peut s’agir de n’importe quelle adresse IPv4. Par souci de simplicité, nous utilisons 1.1.1.1 :

R1(config-rtr)# router-id 1.1.1.1

Pour s’assurer que les coûts des interfaces 10GigE sont calculés avec précision lorsqu’ils sont disponibles, nous changeons la bande passante de référence à 10 000 000 000 bps, ou 10000 Mbps, avec la commande auto-cost reference-bandwidth :

R1(config-rtr)# auto-cost reference-bandwidth 10000
% OSPFv3-10-IPv6: Reference bandwidth is changed.
      Please ensure reference bandwidth is consistent across all routers.

Ce message syslog nous rappelle de le faire sur chaque routeur.

Comme dans OSPFv2, nous pouvons arrêter d’envoyer des mises à jour par l’interface GigabitEthernet 0/0 avec la commande passive-interface:

R1(config-rtr)# passive-interface g0/0

C’est tout pour les commandes de configuration du routeur. Ensuite, nous activons simplement OSPFv3 sur chacune des interfaces actives, comme dans l’exemple H.

Exemple H – Activer OSPFv3 sur les interfaces

R1(config-rtr)# exit
R1(config)# interface GigabitEthernet 0/0
R1(config-if)# ipv6 ospf 10 area 0
R1(config-if)# interface Serial0/0/0
R1(config-if)# ipv6 ospf 10 area 0
R1(config-if)# interface Serial0/0/1
R1(config-if)# ipv6 ospf 10 area 0

Configurez R2 et R3 avec des commandes similaires (nous pouvons utiliser 2.2.2.2 et 3.3.3.3 pour R2 et R3, respectivement), et OSPFv3 est pleinement opérationnel.

Vérification de l’OSPFv3

Dans le Tableau F, notez que chaque commande OSPFv2 affichée est également disponible pour OSPFv3 – remplacez ipv6 par ipv6.

Tableau F – Les commandes show OSPFv2 et OSPFv3 correspondantes

Pour afficher des détails sur....
OSPFv2
OSPFv3
Processus OSPF
show ip ospfshow ipv6 ospf
Toutes les sources d'informations de routageshow ip protocolsshow ipv6 protocols
Détails sur les interfaces activées OSPFshow ip ospf interfaceshow ipv6 ospf interface
Informations concises sur les interfaces activées OSPFshow ip ospf interface briefshow ipv6 ospf interface brief
Liste des voisinsshow ip ospf neighbor
show ipv6 ospf neighbor
Sommaire de la LSDBshow ip ospf databaseshow ipv6 ospf database
Routes apprises par OSPFshow ip route ospfshow ipv6 route ospf

Les exemples I à O montrent la sortie de R1 pour les commandes de vérification OSPFv3 du Tableau F. La commande bandwidth configurée pendant la configuration OSPF pour une zone unique est toujours en vigueur, comme le reflète la sortie pour les valeurs de coût OSPF.

Exemple I – Vérification du processus OSPF

R1# show ipv6 ospf
      Routing Process "ospfv3 10" with ID 1.1.1.1
      Supports NSSA (compatible with RFC 3101)
      Event-log enabled, Maximum number of events: 1000, Mode: cyclic
      Router is not originating router-LSAs with maximum metric
      Initial SPF schedule delay 5000 msecs
      Minimum hold time between two consecutive SPFs 10000 msecs
      Maximum wait time between two consecutive SPFs 10000 msecs
      Minimum LSA interval 5 secs
      Minimum LSA arrival 1000 msecs
      LSA group pacing timer 240 secs
      Interface flood pacing timer 33 msecs
      Retransmission pacing timer 66 msecs
   Retransmission limit dc 24 non-dc 24
      Number of external LSA 0. Checksum Sum 0x000000
      Number of areas in this router is 1. 1 normal 0 stub 0 nssa
      Graceful restart helper support enabled
   Reference bandwidth unit is 1000 mbp
   RFC1583 compatibility enabled
      Area BACKBONE(0)
      Number of interfaces in this area is 3
      SPF algorithm executed 4 times
      Number of LSA 11. Checksum Sum 0x05AD44
      Number of DCbitless LSA 0
      Number of indication LSA 0
      Number of DoNotAge LSA 0
      Flood list length 0
R1#

 

Exemple J – Vérification des sources d’information du routage

R1# show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ospf 10"
   Router ID 1.1.1.1
   Number of areas: 1 normal, 0 stub, 0 nssa
   Interfaces (Area 0):
      Serial0/0/1
      Serial0/0/0
      GigabitEthernet0/0
   Redistribution:
      None
IPv6 Routing Protocol is "ND"
R1#

 

Exemple K – Vérification des détails d’une interface activée OSPF

R1# show ipv6 ospf interface serial 0/0/0
Serial0/0/0 is up, line protocol is up
   Link Local Address FE80::1, Interface ID 6
   Area 0, Process ID 10, Instance ID 0, Router ID 1.1.1.1
   Network Type POINT_TO_POINT, Cost: 6476
   Transmit Delay is 1 sec, State POINT_TO_POINT
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
      Hello due in 00:00:07
   Graceful restart helper support enabled
   Index 1/2/2, flood queue length 0
   Next 0x0(0)/0x0(0)/0x0(0)
   Last flood scan length is 3, maximum is 3
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1
      Adjacent with neighbor 2.2.2.2
   Suppress hello for 0 neighbor(s)
R1#

 

Exemple L – Vérifier l’état d’interface OSPF

R1# show ipv6 ospf interface brief
Interface 	PID 	Area 	Intf ID 	Cost 	State 	Nbrs F/C
Se0/0/1 	10 	0 	7 		65535 	P2P 	1/1
Se0/0/0 	10 	0 	6 		6476 	P2P 	1/1
Gi0/0 		10 	0 	3 		100 	DR 	0/0
R1#

 

Exemple M – Vérification de la table des voisins OSPF

R1# show ipv6 ospf neighbor

    OSPFv3 Router with ID (1.1.1.1) (Process ID 10)

Neighbor ID 	Pri 	State 	Dead Time 	Interface ID 	Interface
3.3.3.3 	0 	FULL/ - 00:00:31 	6 		Serial0/0/1
2.2.2.2 	0 	FULL/ - 00:00:38 	6 		Serial0/0/0
R1#

 

Exemple N – Vérification de la base de données d’état de liaison OSPF

R1# show ipv6 ospf database

    OSPFv3 Router with ID (1.1.1.1) (Process ID 10)

      Router Link States (Area 0)

ADV Router 	Age 	Seq# 		Fragment ID 	Link count 	Bits
1.1.1.1 	1042 	0x80000004 	0 		2 		None
2.2.2.2 	1264 	0x80000002 	0 		2 		None
3.3.3.3 	1260 	0x80000002 	0 		2 		None

      Link (Type-8) Link States (Area 0)

ADV Router 	Age 	Seq# 		Link ID 	Interface
1.1.1.1 	1042 	0x80000002 	7 		Se0/0/1
3.3.3.3 	1265 	0x80000001 	6 		Se0/0/1
1.1.1.1 	1042 	0x80000002 	6 		Se0/0/0
2.2.2.2 	1313 	0x80000001 	6 		Se0/0/0
1.1.1.1 	1042 	0x80000002 	3 		Gi0/0

      Intra Area Prefix Link States (Area 0)

ADV Router 	Age 	Seq# 		Link ID 	Ref-lstype 	Ref-LSID
1.1.1.1 	1042 	0x80000003 	0 		0x2001 		0
2.2.2.2 	1308 	0x80000002 	0 		0x2001 		0
3.3.3.3		1260 	0x80000002 	0 		0x2001 		0
R1#

 

Exemple O – Vérification des routes OSPF dans la table de routage

R1# show ipv6 route ospf
IPv6 Routing Table - default - 10 entries
<texte omis>
O    2001:DB8:1:2::/64 [110/6576]
      via FE80::2, Serial0/0/0
O    2001:DB8:1:3::/64 [110/16341]
      via FE80::2, Serial0/0/0
O    2001:DB8:1:B::/64 [110/16241]
      via FE80::2, Serial0/0/0
R1#

 

 

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image