Configurer et dépanner le routage inter-VLAN

Configurer et dépanner VTP et le routage inter-VLAN

Comme les commutateurs de couche 2 ne peuvent pas exécuter la fonction de routage, il est nécessaire d’implémenter un périphérique de couche 3 pour router entre les VLANs. Dans cet article, on va étudier les concept du routage inter-VLAN et de routeur sur bâton.

En addition, vous allez apprendre à configurer et dépanner le routage inter-VLAN.

Concepts de routage inter-VLAN

Les communications inter-VLAN ne peuvent pas se faire sans un périphérique de couche 3. Trois options sont disponibles lors de l’implémentation du routage inter-VLAN :

  • Routage inter-VLAN traditionnel ou ancien
  • Routage sur bâton (Router on a stick)
  • Commutateur multicouche

Revoyons brièvement le concept de chaque méthode.

Routage inter-VLAN ancien

L’ancien routage inter-VLAN nécessite de multiples interfaces physiques sur le routeur et le commutateur. Lorsque vous utilisez un routeur pour faciliter le routage inter-VLAN, les interfaces du routeur peuvent être connectées à des VLAN séparés.

Les périphériques de ces VLAN envoient du trafic par le routeur pour atteindre d’autres VLAN.

Par exemple, dans la Figure A, chaque interface S2 connectée à R1 est affectée à un VLAN. Le routeur est déjà configuré avec l’adresse IP appropriée sur chacune de ses interfaces, aucune configuration supplémentaire n’est donc nécessaire.

Cependant, vous pouvez voir que si vous utilisez une interface séparée pour chaque VLAN sur un routeur, vous seriez rapidement à la recherche d’interfaces.

Figure A - Routage inter-VLAN ancien
Figure A – Routage inter-VLAN ancien

Routeur sur bâton

Aujourd’hui, le Cisco IOS versions routeur permet de configurer une interface de routeur comme plusieurs troncs en utilisant des sous-interfaces. Dans la Figure B, l’interface physique GigabitEthernet 0/0 est logiquement subdivisée en deux interfaces logiques.

Le trunk d’un commutateur est configuré pour faire passer à la fois le trafic du VLAN 10 et du VLAN 30, et chaque sous-interface du routeur est affectée à un VLAN séparé. Le routeur effectue le routage inter-VLAN en acceptant le trafic étiqueté VLAN sur l’interface principale provenant du commutateur adjacent.

Le routeur redirige ensuite le trafic routé, marqué VLAN pour le VLAN de destination, vers la même interface physique qu’il utilisait pour recevoir le trafic.

Figure B - Routeur sur un bâton
Figure B – Routeur sur un bâton

Commutateur multicouche

Le concept de routeur sur bâton fonctionne bien dans une petite entreprise avec un ou deux routeurs.

Mais la solution la plus évolutive dans les réseaux d’entreprise d’aujourd’hui consiste à utiliser un commutateur multicouche pour remplacer à la fois le routeur et le commutateur, comme le montre la Figure C.

Un commutateur multicouche remplit les deux fonctions : commutation du trafic dans le même VLAN et routage du trafic entre les VLAN.

Figure C - Commutateur multicouche
Figure C – Commutateur multicouche

Pour ces raisons, la commutation multicouche est plus évolutive que toute autre implémentation de routage inter-VLAN :

  • Les routeurs disposent d’un nombre limité d’interfaces disponibles pour se connecter aux réseaux.
  • Des quantités limitées de trafic peuvent être prises en charge sur la liaison physique en même temps.

Avec un commutateur multicouche, les paquets sont acheminés sur un seul lien trunk pour obtenir de nouvelles informations d’étiquetage VLAN. Un commutateur multicouche ne remplace pas complètement la fonctionnalité d’un routeur, mais peut être considéré comme un dispositif de couche 2 qui est mis à niveau pour avoir certaines capacités de routage.

Configuration et vérification du routeur sur bâton

Lors de la configuration du routage inter-VLAN à l’aide du routeur sur un bâton, l’interface physique du routeur doit être connectée à une liaison trunk sur le commutateur adjacent.

Sur le routeur, des sous-interfaces sont créées pour chaque VLAN unique du réseau. Chaque sous-interface se voit attribuer une adresse IP spécifique à son sous-réseau/VLAN et est également configurée pour baliser les trames de ce VLAN.

De cette façon, le routeur peut garder le trafic de chaque sous-interface séparé pendant qu’il traverse la liaison trunk vers le commutateur.

La configuration du routage inter-VLAN est assez simple. Reportez-vous à l’exemple de topologie de la Figure D pour passer en revue les commandes.

Figure D - Topologie de routage inter-VLAN
Figure D – Topologie de routage inter-VLAN

Cette topologie de routeur sur bâton est configurée en suivant les étapes suivantes effectuées sur le routeur :

Étape 1. Activez l’interface physique trunk connectée au commutateur à l’aide de la commande no shutdown.

Étape 2. Entrez dans le mode de configuration de sous-interface pour le premier VLAN qui a besoin d’être routé. Une convention consiste à utiliser le numéro VLAN comme numéro de sous-interface. Par exemple, la commande interface g0/1.10 entre en mode configuration sous-interface pour VLAN 10.

Étape 3. Configurez le type d’encapsulation trunking en utilisant la commande de configuration de sous-interface encapsulation {dot1q | isl} vlan-number [native]. Réglez l’encapsulation sur dot1q.

  • L’encapsulation de liaison inter-commutateurs (ISL), une méthode propriétaire Cisco de trunking, existait avant la norme IEEE 802.1Q, qui est maintenant la meilleure pratique recommandée. Cependant, les commutateurs plus anciens qui sont encore utilisés peuvent ne prendre en charge que l’ISL. Dans ces cas, vous remplacez dot1q par le mot-clé isl.
  • Sur certains routeurs, le mot-clé optionnel native doit être configuré pour spécifier le VLAN natif avant que le routeur n’achemine le trafic du VLAN natif. Les exemples suivants n’utilisent pas de routage VLAN natif.

Étape 4. Configurez l’adresse IP et le masque de sous-réseau.

Étape 5. Répétez les étapes 2 à 4 pour chaque VLAN supplémentaire à router.

En supposant que le commutateur est déjà configuré avec les VLAN et le trunking, l’exemple E montre les commandes pour configurer R1 afin qu’il assure le routage entre VLAN 10 et VLAN 30.

Exemple A – Configuration du routage inter-VLANs sur R1

R1(config)# interface g0/0
R1(config-if)# no shutdown
R1(config-if)# interface g0/0.10
R1(config-subif)# encapsulation dot1q 10
R1(config-subif)# ip address 172.17.10.1 255.255.255.0
R1(config-subif)# interface g0/0.30
R1(config-subif)# encapsulation dot1q 30
R1(config-subif)# ip address 172.17.30.1 255.255.255.0

Pour vérifier la configuration, utilisez les commandes show vlans, show ip route et show ip interface brief pour vous assurer que les nouveaux réseaux sont dans la table de routage et que les sous-interfaces sont bien en place, comme dans l’exemple B.

Exemple B – Vérification de la configuration du routage inter-VLAN

R1# show vlans
<texte omis>
Virtual LAN ID: 10 (IEEE 802.1Q Encapsulation)
  vLAN Trunk Interface: GigabitEthernet0/0.10
  Protocols Configured: 	Address:	 Received:	 Transmitted:
    IP 		172.17.10.1 	 0 		0
<texte omis>
Virtual LAN ID: 30 (IEEE 802.1Q Encapsulation)
  vLAN Trunk Interface: GigabitEthernet0/0.30
  Protocols Configured: 	Address: 	Received: 	Transmitted:
    IP 		172.17.30.1 	0 		0
<texte omis>

R1# show ip route
<texte omis>

Gateway of last resort is not set

  172.17.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 		172.17.10.0/24 is directly connected, GigabitEthernet0/0.10
L 		172.17.10.1/32 is directly connected, GigabitEthernet0/0.10
C 		172.17.30.0/24 is directly connected, GigabitEthernet0/0.30
L 		172.17.30.1/32 is directly connected, GigabitEthernet0/0.30

R1# show ip interface brief
Interface 		IP-Address 	OK? Method 	Status 			Protocol
GigabitEthernet0/0 	unassigned 	YES unset 	up 			up
GigabitEthernet0/0.10 	172.17.10.1 	YES manual 	up 			up
GigabitEthernet0/0.30 	172.17.30.1	YES manual 	up 			up
GigabitEthernet0/1 	unassigned 	YES unset 	administratively down 	down
Serial0/0/0 		unassigned 	YES manual 	administratively down 	down
Serial0/0/1 		unassigned 	YES manual 	administratively down 	down
Vlan1 			unassigned 	YES manual 	administratively down 	down
R1#

En supposant que le commutateur et les PC sont configurés correctement, les deux PC devraient maintenant être capables de pinguer l’un l’autre. R1 achemine le trafic entre VLAN 10 et VLAN 30.

Configuration et vérification du routage inter-VLAN des commutateurs multicouches

La plupart des réseaux d’entreprise utilisent des commutateurs multicouches pour atteindre des taux de traitement de paquets élevés en utilisant la commutation matérielle. Tous les commutateurs multicouches Catalyst prennent en charge les types suivants d’interfaces de couche 3 :

Switch virtual interface (SVI) : Interface VLAN virtuelle utilisée pour le routage inter-VLAN

Routed port : Semblable à une interface physique sur un routeur Cisco IOS

Tous les commutateurs Cisco Catalyst de couche 3 prennent en charge les protocoles de routage (séries 3500, 4500 et 6500). Les commutateurs Catalyst 2960 Series fonctionnant sous Cisco IOS version 12.2(55) ou ultérieure prennent en charge le routage statique.

Création d’interfaces SVI supplémentaires

La SVI du VLAN par défaut (VLAN1) existe déjà pour permettre la gestion à distance des commutateurs. Pour une topologie telle que celle de la figure E, il faut créer explicitement d’autres SVI.

Figure E - Interfaces virtuelles commutées SVI
Figure E – Interfaces virtuelles commutées SVI

Créez une SVI à l’aide de la commande vlan vlan-id en mode configuration d’interface. Le vlan-id utilisé correspond à l’étiquette VLAN associée aux trames de données provenant de ce VLAN.

Par exemple, lors de la création d’une SVI comme passerelle pour VLAN 10, utilisez la commande interface VLAN 10. Attribuez une adresse IP et activez la nouvelle SVI avec la commande no shutdown.

De plus, le commutateur doit être configuré pour effectuer le routage de couche 3 avec la commande de configuration globale ip routing.

Voici quelques avantages des SVIs (le seul inconvénient est que les commutateurs multicouches sont plus chers) :

  • Ils sont beaucoup plus rapides que les routeurs sur une clé USB parce que tout est matériel commuté et routé.
  • Aucune liaison externe n’est nécessaire entre le commutateur et le routeur pour le routage.
  • Ils ne se limitent pas à un seul lien. Les canaux EtherChannels de couche 2 peuvent être utilisés entre les commutateurs pour obtenir plus de bande passante.
  • La latence est beaucoup plus faible parce qu’il n’a pas besoin de quitter le commutateur.

L’exemple C montre la configuration du commutateur de couche 3 de la Figure E.

Exemple C – Configuration d’un commutateur pour utiliser les SVI dans le routage

MLS(config)# ip routing
MLS(config)# vlan 10
MLS(config)# vlan 30
MLS(config)# interface vlan 10
MLS(config-if)# ip address 172.17.10.1 255.255.255.0
MLS(config-if)# interface vlan 30
MLS(config-if)# ip address 172.30.10.1 255.255.255.0
MLS(config-if)# interface f0/11
MLS(config-if)# switchport mode access
MLS(config-if)# switchport access vlan 10
MLS(config-if)# interface f0/6
MLS(config-if)# switchport mode access
MLS(config-if)# switchport access vlan 30
MLS(config-if)# end
MLS# show ip route

<texte omis>
Gateway of last resort is not set

  172.17.0.0/24 is subnetted, 2 subnets
C 		172.17.10.0 is directly connected, Vlan10
C		172.17.30.0 is directly connected, Vlan30
MLS#

Comme la commande ip routing est configurée, le MLS (switch multi-couches) dispose d’une table de routage. PC1 et PC3 peuvent maintenant se pinguer l’un l’autre.

Configuration d’un port routé de couche 3

Dans la Figure E, notez que l’interface GigabitEthernet 0/1 a une adresse IP qui lui est attribuée. Pour configurer cette interface en tant que port routé, désactivez la commutation avec la commande de configuration d’interface no switchport.

Configurez ensuite l’adresse IP comme d’habitude. La commande ip routing a été activée à l’étape précédente. Cependant, le commutateur de couche 3 a toujours besoin d’une route par défaut pour envoyer du trafic vers Internet.

L’exemple D montre les commandes pour configurer le port routé et la route par défaut.

Exemple D – Configuration d’un commutateur avec un port routé

MLS(config)# interface g0/1
MLS(config-if)# no switchport
MLS(config-if)# ip address 192.0.2.2 255.255.255.0
!The no shutdown command is not required because switch interfaces are already
  activated.
MLS(config-if)# exit
MLS(config)# ip route 0.0.0.0 0.0.0.0 g0/1
MLS(config)# exit
MLS# show ip route
<texte omis>

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

  172.17.0.0/24 is subnetted, 2 subnets
C 		172.17.10.0 is directly connected, Vlan10
C 		172.17.30.0 is directly connected, Vlan30
C 	192.0.2.0/24 is directly connected, GigabitEthernet0/1
S* 	0.0.0.0/0 is directly connected, GigabitEthernet0/1
MLS#

La commande show ip route vérifie que le commutateur de couche 3 a une route vers Internet. PC1 et PC3 peuvent maintenant accéder au serveur web.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image