Configurer et vérifier EIGRP pour IPv4/IPv6

Configurer et vérifier EIGRP pour IPv4/IPv6

Enhanced IGRP (EIGRP) est facile à mettre en place et à utiliser avec une configuration de base. Toutefois, pour tirer pleinement parti de EIGRP, vous devez effectuer diverses tâches de configuration pour modifier la configuration de base. L’article d’aujourd’hui porte sur la configuration et la vérification de base du EIGRP pour IPv4 et IPv6. L’article sera axé sur la modification et le dépannage de l’EIGRP.

Configuration EIGRP pour IPv4

Cette section couvre les bases de la configuration d’EIGRP pour IPv4, y compris les commandes network et router-id.

Topologie et schéma d’adressage de EIGRP

Cet article sur les commandes de configuration EIGRP utilise la topologie de la Figure A et le schéma d’adressage du Tableau A.

Tableau A – Schéma d’adressage pour l’EIGRP

AppareilInterfaceAdresse IPMasque de sous-réseau
R1G0/0172.16.1.1255.255.255.0
S0/0/0172.16.3.1255.255.255.252
S0/0/1192.168.10.5255.255.255.252
R2G0/0172.16.2.1255.255.255.0
S0/0/0172.16.3.2255.255.255.252
S0/0/1192.168.10.9255.255.255.252
S0/1/0209.165.200.225255.255.255.224
R3G0/0192.168.1.1255.255.255.0
S0/0/0192.168.10.6255.255.255.252
S0/0/1192.168.10.10255.255.255.252

 

Figure A - Topologie de la configuration EIGRP
Figure A – Topologie de la configuration EIGRP

La commande network

En supposant que les interfaces de tous les routeurs sont configurées et activées en fonction des adresses IP du Tableau A, l’exemple A montre la configuration EIGRP en utilisant la commande network.

Exemple A – Configuration EIGRP

R1(config)# router eigrp 1
R1(config-router)# network 172.16.0.0
R1(config-router)# network 192.168.10.0

R2(config)# router eigrp 1
R2(config-router)# network 172.16.0.0
R2(config-router)# network 192.168.10.0

R3(config)# router eigrp 1
R3(config-router)# network 192.168.1.0
R3(config-router)# network 192.168.10.0

 

L’ID du routeur

L’ID du routeur est utilisé dans les protocoles de routage EIGRP et OSPF, bien que le rôle de l’ID du routeur soit plus important dans OSPF.

Les routeurs Cisco dérivent l’ID du routeur en fonction de trois critères, selon l’ordre de priorité suivant :

1. Le routeur utilise l’adresse IPv4 configurée avec la commande eigrp router-id router en mode de configuration routeur.

2. Si l’ID du routeur n’est pas configuré, le routeur choisit l’adresse IPv4 la plus élevée parmi toutes ses interfaces de bouclage (loopback).

3. Si aucune interface de bouclage n’est configurée, le routeur choisit l’adresse IPv4 active la plus élevée parmi toutes ses interfaces physiques.

Pour cet exemple de topologie, vous pouvez configurer explicitement l’ID du routeur, comme dans l’exemple.

Exemple B – Configuration des IDs de routeur pour EIGRP

R1(config)# router eigrp 1
R1(config-router)# eigrp router-id 1.1.1.1

R2(config)# router eigrp 1
R2(config-router)# eigrp router-id 2.2.2.2

R3(config)# router eigrp 1
R3(config-router)# eigrp router-id 3.3.3.3

 

Vérification EIGRP pour IPv4

Cette section présente le contenu de quatre importantes commandes de vérification EIGRP pour IPv4 : show ip protocols, show ip eigrp neighbors, show ip eigrp topology, et show ip route eigrp.

Examen des détails du protocole

L’exemple C montre la sortie de la commande show ip protocols sur R1.

Exemple C – Détails de protocole pour R1

R1# show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(1)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 1.1.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
  Automatic Summarization: disabled
    Maximum path: 4
  Routing for Networks:
    172.16.0.0
    192.168.10.0
  Routing Information Sources:
    Gateway 	Distance 	Last Update
    192.168.10.6 	90 		00:40:20
    172.16.3.2 	90 		00:40:20
  Distance: internal 90 external 170

 

La sortie de l’exemple C montre la vérification de plusieurs détails importants du protocole EIGRP, dont les suivants :

  • EIGRP est un protocole de routage dynamique actif sur R1 configuré avec le système autonome numéro 1.
  • L’ID de routeur EIGRP de R1 est 1.1.1.1.1.
  • Les distances administratives EIGRP sur R1 sont AD interne de 90 et externe de 170 (valeurs par défaut).
  • Par défaut, EIGRP ne résume pas automatiquement les réseaux. Les sous-réseaux sont inclus dans les mises à jour de routage.
  • Les adjacences voisin EIGRP que R1 a avec d’autres routeurs qui sont utilisés pour recevoir les mises à jour du routage EIGRP.

Examen des tables de voisins

La figure B montre la sortie de la commande ip eigrp neighbors sur R1.

Figure B - La table des voisins sur R1
Figure B – La table des voisins sur R1

La sortie de la commande show ip eigrp neighbors comprend les éléments suivants :

Colonne H : Liste les voisins dans l’ordre dans lequel ils ont été appris.

Adresse : Donne l’adresse IPv4 du voisin.

Interface : Indique l’interface locale sur laquelle ce paquet hello a été reçu.

Hold : Indique le temps de maintien actuel. Lorsqu’un paquet hello est reçu, cette valeur est réinitialisée à la valeur de temps de maintien maximal pour cette interface, puis compte à rebours jusqu’à zéro. Si le zéro est atteint, le voisin est considéré comme en panne.

Temps de disponibilité (Uptime): Indique le temps écoulé depuis que ce voisin a été ajouté à la table des voisins.

Temporisateur aller-retour en douceur (SRTT) et délai de retransmission (RTO) : Utilisé par RTP pour gérer les paquets EIGRP fiables.

Nombre de files d’attente (Queue count): Ça devrait toujours être zéro. S’il est supérieur à zéro, des paquets EIGRP attendent d’être envoyés.

Numéro de séquence (Sequence number) : Suivi des mises à jour, des requêtes et des paquets de réponse.

Examen des tableaux de topologie

EIGRP maintient une base de données de la topologie du réseau avec des informations complètes sur les routes, y compris tous les successeurs et successeurs possibles, comme le montre l’exemple D pour R2.

Exemple D – La table de topologie sur R2

R2# show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(1)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
    r - reply Status, s - sia Status
P	172.16.2.0/24, 1 successors, FD is 2816
    via Connected, GigabitEthernet0/0
P	192.168.10.4/30, 1 successors, FD is 3523840
    via 192.168.10.10 (3523840/2169856), Serial0/0/1
    via 172.16.3.1 (41024000/2169856), Serial0/0/0
P	192.168.1.0/24, 1 successors, FD is 3012096
    via 192.168.10.10 (3012096/2816), Serial0/0/1
    via 172.16.3.1 (41024256/2170112), Serial0/0/0
P	172.16.3.0/30, 1 successors, FD is 40512000
    via Connected, Serial0/0/0
P	172.16.1.0/24, 1 successors, FD is 3524096
    via 192.168.10.10 (3524096/2170112), Serial0/0/1
    via 172.16.3.1 (40512256/2816), Serial0/0/0
P	192.168.10.8/30, 1 successors, FD is 3011840
    via Connected, Serial0/0/1
R2#

 

REMARQUE : Pour la sortie de l’exemple B et la discussion qui suit, supposons que la commande bandwidth a été configurée conformément aux valeurs de bande passante indiquées sur la topologie de la Figure A.

Pour examiner les particularités des successeurs EIGRP, des successeurs possibles (feasible successors), de la distance possible (feasible distance), de la distance rapportée et de la condition de faisabilité(feasible condition), nous allons nous concentrer sur la rubrique mise en surbrillance pour 192.168.1.0/24 (voir figure C).

Figure C - 192.168.1.0/24 : Successeur et successeur possible
Figure C – 192.168.1.0/24 : Successeur et successeur possible

R2 a deux routes pour 192.168.1.0/24. La première sous-entrée est une route à travers R3. C’est le successeur et il est installé dans la table de routage parce qu’il a la plus petite distance possible.

La seconde sous-entrée est une route à travers R1. Il s’agit d’un successeur possible parce qu’il répond à la condition de faisabilité, qui stipule que la distance déclarée du successeur possible doit être inférieure à la distance possible du successeur.

La distance rapportée de R1 est inférieure à la distance de faisabilité du successeur de R3. Par conséquent, si le successeur devient indisponible, DUAL peut immédiatement installer le successeur possible sans avoir à exécuter aucun calcul.

La commande show ip eigrp topology all-links affiche toutes les entrées de la table de topologie, y compris les routes qui ne sont pas des successeurs possibles (voir Figure D).

Figure D - 192.168.1.1.0/24 : Successeur, aucun successeur possible
Figure D – 192.168.1.1.0/24 : Successeur, aucun successeur possible

Comme pour R2, R1 a un successeur pour 192.168.1.0/24 ; cependant, R1 n’a pas de successeur possible parce que la route de R2 ne remplit pas la condition de faisabilité.

La distance rapportée pour la route à partir de R2 est supérieure à la distance faisable de la route suivante.

Par conséquent, si le successeur devient indisponible, DUAL doit exécuter son algorithme pour interroger les voisins sur une route potentiellement meilleure avant de pouvoir installer la route à partir de R2.

Examen de la table de routage

Vérifier que toutes les routes attendues sont installées dans les tables de routage est l’un des moyens les plus rapides de vérifier que l’EIGRP est correctement implémenté sur tous les routeurs. L’exemple E montre les tables de routage EIGRP pour les trois routeurs.

Exemple E – Routes EIGRP dans les tables de routage de R1, R2 et R3

R1# show ip route eigrp
  172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
D 		172.16.2.0/24 [90/3524096] via 192.168.10.6, 00:24:34, Serial0/0/1
D 	192.168.1.0/24 [90/2170112] via 192.168.10.6, 00:24:34, Serial0/0/1
    192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D 	192.168.10.8/30 [90/3523840] via 192.168.10.6, 00:24:34, Serial0/0/1
R1#

R2# show ip route eigrp
  172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
D 		172.16.1.0/24 [90/3524096] via 192.168.10.10, 00:25:13, Serial0/0/1
D 		192.168.1.0/24 [90/3012096] via 192.168.10.10, 01:02:22, Serial0/0/1
  192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D 		192.168.10.4/30 [90/3523840] via 192.168.10.10, 00:25:19, Serial0/0/1
R2#

R3# show ip route eigrp
  172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 		172.16.1.0/24 [90/2170112] via 192.168.10.5, 00:25:41, Serial0/0/0
D 		172.16.2.0/24 [90/3012096] via 192.168.10.9, 01:02:44, Serial0/0/1
D 		172.16.3.0/30 [90/41024000] via 192.168.10.9, 01:02:44, Serial0/0/1
            [90/41024000] via 192.168.10.5, 00:25:41, Serial0/0/0
R3#

 

Concepts de EIGRP pour IPv6

EIGRP pour IPv6 a les mêmes fonctionnalités que EIGRP pour IPv4, mais il utilise IPv6 comme protocole transport de la couche réseau, communiquant avec EIGRP pour les pairs IPv6 et annonçant les routes IPv6.

Le tableau B résume les similitudes et les différences entre les versions IPv4 et IPv6 de EIGRP.

Tableau B – Comparaison des EIGRP pour IPv4 et IPv6

CaractéristiqueEIGRP pour IPv4EIGRP pour IPv6
Routes annoncéesRéseaux IPv4Réseaux IPv6
Vecteur de distanceOuiOui
Technologie de convergenceDUALDUAL
MétriqueBande passante et délai par défaut, fiabilité et charge en optionBande passante et délai par défaut, fiabilité et charge en option
Protocole de transportReliable Transport Protocol (RTP)Reliable Transport Protocol (RTP)
Messages de mise à jourMises à jour incrémentales, partielles et bornéesMises à jour incrémentales, partielles et bornées.
Neighbor discoveryPaquets HelloPaquets Hello
Adresses source et destinationAdresse source IPv4 et adresse de destination multidiffusion 224.0.0.10 IPv4Adresse IPv6 source link-local et adresse IPv6 de destination multidiffusion FF02::10
AuthentificationTexte brut et MD5 (algorithme de digestion des messages 5)MD5
ID du routeurID de routeur 32 bitsID de routeur 32 bits

Configuration de EIGRP pour IPv6

Les commandes de configuration EIGRP pour IPv6 sont similaires à celles utilisées dans EIGRP pour IPv4. Cet examen de l’EIGRP pour les commandes de configuration IPv6 utilise la topologie de la Figure E et le schéma d’adressage du Tableau C.

Figure E - Topologie de configuration EIGRP pour IPv6
Figure E – Topologie de configuration EIGRP pour IPv6

Tableau C – Schéma d’adressage d’EIGRP pour IPv6

AppareilInterfaceIPv6 Adresse/Préfixe
R1



G0/02001:DB8:CAFE:1::1/64
S0/0/02001:DB8:CAFE:A001::2/64
S0/0/12001:DB8:CAFE:A003::1/64
Link-localFE80::1
Router ID1.1.1.1
R2G0/02001:DB8:CAFE:2::1/64
S0/0/02001:DB8:CAFE:A001::1/64
S0/0/12001:DB8:CAFE:A002::1/64
S0/1/02001:DB8:FEED:1::2/64
Link-localFE80::2
Router ID2.2.2.2
R3G0/02001:DB8:CAFE:3::1/64
S0/0/02001:DB8:CAFE:A003::2/64
S0/0/12001:DB8:CAFE:A002::2/64
Link-localFE80::3
Router ID3.3.3.3

Pour configurer EIGRP pour IPv6, suivez les étapes suivantes :

Étape 1. Activez le routage IPv6 avec la commande ipv6 unicast-routing en mode configuration globale.

Étape 2. Entrez le mode de configuration routage de EIGRP pour IPv6 avec la commande de configuration globale ipv6 router eigrp AS-number.

Étape 3. Configurez l’ID du routeur 32 bits avec la commande de configuration routeur eigrp router-id IPv4-address.

Étape 4. Le processus EIGRP pour IPv6 démarrera après que vous aurez entré l’ID du routeur. Cependant, EIGRP pour IPv6 a une fonction d’arrêt. Par conséquent, il est préférable d’entrer la commande no shutdown pour s’assurer que le processus est en cours d’exécution.

Étape 5. Activez EIGRP pour IPv6 sur chaque interface désirée avec la commande de configuration interface ipv6 eigrp AS-number.

L’exemple F montre les commandes de configuration sur R2 pour activer EIGRP pour IPv6 sur toutes les interfaces. Les commandes sont les mêmes pour R1 et R3.

Exemple F – Activation d’EIGRP pour IPv6 sur R2

R2(config)# ipv6 unicast-routing
R2(config)# ipv6 router eigrp 100
R2(config-rtr)# eigrp router-id 2.2.2.2
R2(config-rtr)# no shutdown
R2(config-rtr)# interface g0/0
R2(config-if)# ipv6 eigrp 100
R2(config-if)# interface s0/0/0
R2(config-if)# ipv6 eigrp 100
R2(config-if)# interface s0/0/1
R2(config-if)# ipv6 eigrp 100
R2(config-if)# end
R2#

 

Vérification de EIGRP pour IPv6

Les commandes de vérification EIGRP pour IPv6 sont similaires à celles utilisées dans EIGRP pour IPv4. Il suffit de remplacer le mot clé ip par ipv6. Cette section examine le contenu de trois importantes commandes de vérification EIGRP pour IPv6 : show ipv6 protocols, show ipv6 eigrp neighbors, et show ipv6 route eigrp.

Examen des détails du protocole

L’exemple G montre la sortie de la commande show ipv6 protocols sur R1.

Exemple G – Détails de protocole de R1

R1# show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "eigrp 100"
EIGRP-IPv6 Protocol for AS(100)
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  NSF-aware route hold timer is 240
  Router-ID: 1.1.1.1
  Topology : 0 (base)
    Active Timer: 3 min
    Distance: internal 90 external 170
    Maximum path: 16
    Maximum hopcount 100
    Maximum metric variance 1
  Interfaces:
    GigabitEthernet0/0
    Serial0/0/0
    Serial0/0/1
  Redistribution:
    None
R1#

 

La sortie de l’exemple B montre la vérification de plusieurs détails importants du protocole EIGRP, dont les suivants :

  • EIGRP pour IPv6 est un protocole de routage dynamique actif sur R1 configuré avec le numéro de système autonome 100.
  • Les k valeurs utilisées pour le calcul de la métrique composite sont les mêmes que dans EIGRP pour IPv4.
  • L’ID de routeur EIGRP de R1 est 1.1.1.1.1.
  • Comme pour EIGRP pour IPv4, les distances administratives sur R1 sont AD interne de 90 et externe de 170 (valeurs par défaut).
  • Les interfaces activées pour EIGRP pour IPv6.

Examen de la table des voisins

La figure F montre la sortie de la commande ipv6 eigrp neighbors sur R1.

Figure F - La table des voisins de R1
Figure F – La table des voisins de R1

La sortie de la commande show ipv6 eigrp neighbors inclut ce qui suit :

Colonne H : Liste les voisins dans l’ordre dans lequel ils ont été appris.

Adresse : Donne l’adresse IPv6 locale du voisin.

Interface : Indique l’interface locale sur laquelle ce paquet hello a été reçu.

Hold : Indique le temps de maintien actuel. Lorsqu’un paquet hello est reçu, cette valeur est réinitialisée au temps de maintien maximum pour cette interface et compte ensuite à rebours à zéro. Si zéro est atteint, le voisin est considéré comme en panne.

Temps de disponibilité : Indique le temps écoulé depuis que ce voisin a été ajouté à la table des voisins.

SRTT et RTO : Utilisé par RTP pour gérer les paquets EIGRP fiables.

Nombre de files d’attente : Ça devrait toujours être zéro. S’il est supérieur à zéro, des paquets EIGRP attendent d’être envoyés.

Numéro de séquence : Suivi des mises à jour, des requêtes et des paquets de réponse.

Examen de la table de routage

Vérifier que toutes les routes attendues sont installées dans les tables de routage est l’un des moyens les plus rapides de vérifier que EIGRP pour IPv6 est correctement implémenté sur tous les routeurs. L’exemple H montre les tables de routage EIGRP sur les trois routeurs.

Exemple H – Routes EIGRP pour IPv6 dans les tables de routage de R1, R2, et R3

R1# show ipv6 route eigrp
D 	2001:DB8:CAFE:2::/64 [90/2170112]
    via FE80::2, Serial0/0/0, receive
D 	2001:DB8:CAFE:3::/64 [90/2170112]
    via FE80::3, Serial0/0/1, receive
D 	2001:DB8:CAFE:A002::/64 [90/2681856]
    via FE80::2, Serial0/0/0, receive
    via FE80::3, Serial0/0/1, receive
R1#

R2# show ipv6 route eigrp
D	 2001:DB8:CAFE:1::/64 [90/2170112]
    via FE80::1, Serial0/0/0, receive
D 	2001:DB8:CAFE:3::/64 [90/2170112]
    via FE80::3, Serial0/0/1, receive
D 	2001:DB8:CAFE:A003::/64 [90/2681856]
    via FE80::1, Serial0/0/0, receive
    via FE80::3, Serial0/0/1, receive
R2#

R3# show ipv6 route eigrp
D 	2001:DB8:CAFE:1::/64 [90/2170112]
    via FE80::1, Serial0/0/0, receive
D 	2001:DB8:CAFE:2::/64 [90/2170112]
    via FE80::2, Serial0/0/1, receive
D 	2001:DB8:CAFE:A001::/64 [90/2681856]
    via FE80::1, Serial0/0/0, receive
    via FE80::2, Serial0/0/1, receive
R3#

 

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here


CAPTCHA Image
Reload Image